mBlock 5 Bluetooth version


#1

Hi all, recently we have released mBlock 5-RC3 version which allows us to connect mBot and Ranger to mBlock 5 through PC built-in Bluetooth Adapter.

But we still strongly suggest to use USB cable for online programming, reset/update firmware or uploading programs;
If you want to get rid of cables, you are suggested to use Makeblock Bluetooth Dongle (https://store.makeblock.com/bluetooth-dongle-en) which allows us to do online programming and uploading. It really guarantee the connection experience. Especially for windows users as windows system Bluetooth doesn’t have good compatibility, which bring a lot of obstacles for us to meet this “direct connection” feature.

If you want to try use Bluetooth direct connection, please refer to:
http://www.mblock.cc/doc/en/part-one-basics/connect-devices.html

Please notice this only works for mBot and Ranger. And through this method, we can run online program instead of upload program or firmware update. Therefore it is necessary to update firmware through USB connection before use the Bluetooth connection.

For windows, you might need to install Zadig driver (for LMP 7.x and 8.x, you can also have a try):

  1. Download Zadig tool

  2. Run Zadig tool, choose Options and click List All Devices.
    image

  3. Choose your device from the drop-down list and click Replace Driver.
    image

Once we installed the Zadig driver, the computer’s Bluetooth is gone as it was turned to universal serial. That is normal that Bluetooth is closed and we can find it under device manager->universal serial bus controller.

After that if the mBlock 5-RC3 still cannot detect the device in Bluetooth 4.0, and you want to recover the computer Bluetooth, we need to uninstall the driver we installed. Go to device manager->universal serial bus controller->choose the device and right click on it->properties->drivers->uninstall :


Then restart computer and computer will recover its original Bluetooth feature.

If there is no device detected through Bluetooth in mBlock 5-RC3 version after installing Zadig driver, users can offer the information to us and our engineers will update online. The information include the computer’s Bluetooth hardware ID info, see below:

But we cannot guarantee that it will work after we add the correct Bluetooth hardware ID. For better connection experience, we still suggest Makeblock Bluetooth Dongle which also supports uploading programs.

Now mBlock 5 latest version is 5.0.1, please install the latest one.


Mblock wont connect to Bluetooth
Connecting mBot Ranger with bluetooth
Mblock 5 bluetooth connection issue
Bluetooth connection doesn't work with mblock
Mblock v3.4.11 on Win10 - no bluetooth connection to mbot
New or old bluetooth module
Mbot not connecting to Bluetooth
Problem with Auriga bluetooth control from PC
Ultrasonic sensor, strange reading
mBlock 3.4.12 Bluetooth connection
Bluetooth connection to other devices
#2

mBlock 5 Bluetooth version for Windows (V5.0.0-Bluetooth4.0.exe) is unable to detect my mBot. The mBot does not appear in the list while scanning for devices. The Bluetooth connection works fine with mBlock_win_V3.4.11.exe on the same computer and with the Android app, so the Bluetooth module seems to be ok. What can I do?


#3

Please take a photo of your Bluetooth module for me.


#4

Have a similar issue: new mBot (Bluetooth module 1.0_c , latest firmware updated via USB from mBlock 5 Windows Bluetooth version) could not be detected via mBlock 5 using bluetooth.

The HP notebook (has Bluetooth 4.0) can detect it and could pair it, but mBlock will never see it (tried both: pair it or not pair it via Windows Bluetooth menu).

Using the Samsung tablet everything works perfekt with the app…any idea?


#5

See the photo here.


#6

@hl_angel @mbe
Sorry for the issue caused, to further check it, please check the computer information for us:

  1. Press Win+X to open the Start Menu and select Device Manager.
  2. Under Bluetooth, you will see several Bluetooth devices.
  3. Select your Bluetooth brand and right click to check the Properties.
  4. Go to the Advanced tab and check the firmware version. The LMP number shows the version of Bluetooth your PC is using.
    Take a screen shot here for me.

Please take a video of the process how you pair and connect Bluetooth with mBlock-Bluetooth version. I will feedback that to the software team.


#7

@tech_support
I made a screencast showing the successful connection with mBlock 3.4.11 as well as the unsuccessful connection with mBlock 5.0.0. See here.
Starting from 00:04:55, you can see the requested information on the Bluetooth version.


#8

Similar to mbe I have the German version ;-). One screenshot of the Bluetooth settings, one that I can pair from Windows 10 (so the device could be detected by the system, but nevertheless if I do it or not:

mBlock5 will never detect it) and the last from mBlock5 Bluetooth version trying to find it…


#9

Hi mbe,
Sorry, it seems that I cannot reach dropbox website. I cannot open your link.
Will you just tell me your LMP number?
@mbe @hl_angel checked that current mBlock Bluetooth version supports Bluetooth 4.0, that means the LMP number should be 6.xxx; So I am afraid that is the reason why your mBlock doesn’t detect Makeblock device.
Bluetooth 4.1 (LMP7.XX) and 4.2(LMP8.xx) will be supported in the next version.


#10

Ok, many thanks, I thought that the 4.2 detects 4.0 and handles it in a compatibility mode (should be backward compatible according to Bluetooth spec) as the tablet also does it (has 4.2 too) where it works. So I stop trying it now with the PC and wait for the updated version --any hint when you plan to release it?


#11

@tech_support
Yes, I have LMP 8.4096.


#12

The newer version should be released in 2-3 weeks. Let us wait it.


#13

I am facing the same issue, the Bluetooth 4.0 with LMP 8.4096 is not connecting to Mblock RC3 however i have installed Mblock 3.0 and it connects fine. When is the updated version of Mblock with support of LMP 8.4096 expcted?