mBlock 5 Bluetooth version


#21

Hello xmartino,
We are going to release a newer mBlock 5 version, the Bluetooth connection issue with windows 10, which will be solved. Let’s wait it.


#22

Is there a timescale for the new release?


#23

Hi coldpenguin,
We released the version, please uninstall the original version completely, then download the latest version 5.1.


#24

I have tried on two machines. Both of them only had 5.1 installed to begin with.


#25

With latest version, mBot still cannot connect to mblock 5 in Bluetooth?
Could you give me Bluetooth information of your two computers? Both are windows 10?
And can I have a photo of the mBot/ranger’s Bluetooth module?


#26

The cconnection is made, BUT makeblock says that the firmware must be updated via USB, but even when updated via USB it still connects and says it nees ot be updated via USB
This is from the surface book 2
image
Both machines are windows 10
I provided a video if the issue as described here: Mbot with mblock5 bluetooth on windows 10 broken for "live" mode


#27

Bluetooth finally works for me, thanks a lot.

EDIT: It only connects fine. When I do this:

when space key pressed
LED all shows color red for 1 secs

and I press the space bar, the mBot does nothing, yet over USB it works perfectly fine. Also, on Bluetooth it keeps complaining about a firmware update, but not on USB. (I flashed the latest firmware multiple times, but to no avail.)


#28

Bluetooth connection works fine for me (tested on two different computers with Windows 10). I have not noticed any issues with LED lights as described by duje.mihanovic13.

Good work! Thank you very much.


#29

Congratulations :blush:


#30

Is it windows 10?
And have you ever tried uninstall the zadig driver and recover the windows Bluetooth driver?
Could you also take a video for me about “frequently ask for firmware update”?


#31

Is it windows 10?
And have you ever tried uninstall the zadig driver if you installed before and recover the windows Bluetooth driver?


#32

Yes, both machines are windows 10.
Zadig is not installed, and is not necessary to make it work with mblock 3


#33

Once update program with USB connection, connect through Bluetooth, go to use its online feature, just ignore the reminder. What will happen? Maybe it is a wrong warning.
If you always use USB connection, will it remind you to update program again and again after you have already updated program?


#34

The USB connection works, but yes, I can always update the firmware through USB (this must be by design though, as otherwise you can’t change the firmware back to default).
No, selecting the following:
When ‘Green Flag’ clicked
Move forward 100% for 10 seconds
Wait 1 Second
stop All

pressing the green flag makes the block light up with a yellow border, the update button appears, and the robot does not move.


#35

Can we have a remote access? I am available from 9:00 am to 18:30 pm, Mon-Fri, China time.


#36

That will not be feasible at the moment.

What is it you need me to do?


#37

Is it possible that connect wrong device? When it says connected, is the mBot Bluetooth light solid on? Do you have other Makeblock device nearby?


#38

Pretty confident it is the correct device. The name comes up as Makebot_le (I believe), the light on the mbot is flashing until the connection is made, then goes solid blue.
There are no other mbots on in the vicinity when I try this.


#39

Sorry for the issue caused, we have engineer is testing and trying to fix it. Will notify you here.
Thank you for your patience.