Makeblock Ultimate 1.0 "Failed to load firmware"


I was given the Makeblock Ultimate 1.0 kit, the first launch was successful - the robot connected to the mobile application (Android) and could be controlled. The next day, when I tried to connect the robot, I received the error “Unidentified firmware, update using the desktop version of the program.”
I downloaded the latest version of mBlock 5 from the website, disabled the Bluetooth module and connected the robot via USB. mBlock detects the robot, but for further work it requires updating the firmware… When I try to update the firmware, I get an error - Failed to load firmware. I tried installing an older version of mBlock, but it didn’t help.
Windows 10 OS.
The robot looks very high quality, but this problem with the firmware is very disappointing. I read various topics on the forum, but did not find a solution there.

Thank you in advance for your cooperation!



Will the robot still connect to the mobile app?
Also, just update the firmware once, then ignore other messages. There is a glitch. You can also install mLink and try the web version at to troubleshoot farther.

Please provide some additional info or screenshots, too, as it would help me troubleshoot. Thanks!

P.S. In the web version, Press CTRL+SHIFT+I after connecting (also note that this works in Chrome only) and see if any error messages appear in the “Console” tab throughout the connection process. You may also contact mBlock directly through
Best of luck!


Make sure that you have no other USB devices (e.g. a printer) connected.


It was possible to update the firmware through the application version 3.4.12, but the mobile application still gives an error during synchronization.
I disconnected all equipment from USB when trying to update the firmware.


I tried to run the simplest program - nothing happens ((


What happened when you tested in the web version? (If you have yet)



So did it work? I need a bit more info… @AlexG


The online version does not work - it connects to the board, but does not update the firmware. Gives an error message.
I tried to make a very simple program to start one motor - nothing happens. I tried it in the online version and in different desktop versions. But the connected ultrasonic sensor works - it shows the distance in real time.


What is the error message?


Firmware upload error

When connecting via a mobile application (Androit) - it connects to the device, synchronization begins and then displays the error: Unidentified firmware version.


Are there any errors in the browser console? (Press CTRL + SHIFT + I to see it).

And are you certain that the firmware needs to be updated? What happens currently if you just upload a code?



Browser console:

I made a simple program:

When I try to upload it, I get an error:


When ORION starts up ? - Surely you should be using MegaPi here?


I have an Orion board


Hi Alex

Whoops, sorry! - I realised as soon as I posted my previous offering that your post was headed Makeblock Ultimate 1.0 and I do know that this (now very old) kit is Orion driven. I have a Makeblock Ultimate 2.0 which is MegaPi driven.

I do have a couple of Orion boards (from old ‘Starter’ kits), so I have played with them and have not had any firmware problems with either. Both boards update the firmware quite happily using the latest mBlock version. I use the desktop version on a Windows 11 PC and tend not to use the Web version.

I think that you might have a dodgy board! Was this a second-hand purchase?



This set was given to my daughter. Perhaps it was not new, but all the elements were packed


By the browser console, it appears that it can’t connect to mLink. Did you try in Chrome? And make sure that you select the correct port, as the timeout is likely a port issue.


I used Chrome. I’m sure the select pot was correct - I tried to connecting a different USB port.
Most likely there is a problem with the board and I will need to buy a new board((


It may be a software issue. You have made sure that the USB you are using is a data USB and not just a charging one, right? I hope you don’t need a new board. :confused: