Programs to Not Execute


#1

When we first got Codey Rocky … we used the Makeblock app for control and programming.

Recently when we push code … we are redirected to the mBlock app on iOS. We can program and upload … BUT NOTHING HAPPENS.

It is the same with my MacBook running Catalina. I bought the USB adaptor (which is kind of silly since we have a perfectly good bluetooth antenna) and I can connect to Codey and upload the program. BUT NOTHING HAPPENS.

The firmware says it is up to date when checked in the Makeblock app.

I have seen people post similar issues.

What is going on? This terribly frustrating. We spent a $100 and can’t even upload a simple program.

Please advise.


#2

Hi rockybear,

Since Makeblock seems to be on Chinese New Year’s holiday, I will try to help. The Codey Rocky has always worked well with us, even with my IOS tablet. Unfortunately, I am having problems with the new IOS version and mBlock. Conclusion: I keep looking. However, my problem is different since my Codey simply does not connect. Works with Android and my PC but not under the new IOS.

  1. You must switch from one Firmware to another for the PC / MAC user and a tablet.

  2. For my part, I have the same question for the Bluthooh, it would be more pleasant if it works with the antenna of my computer. However, the Makeblock adapter works great and USB as a last resort.

  3. Personally, I use the tutorial of the mBlock application on a tablet but for programming, nothing better than a PC / MAC.

I suggest connecting to USB, updating the latest firmware and trying to display the letter A. <- Is it functional ???

Once your problem is corrected (with the help of Makeblock), I will be better to answer your questions. The Codey has a lot of potential. If you have questions in graphics or Python, I will be available.


#3

Hi Crackel … thanks for getting back. Much appreciated.

Two questions:

#1 - Where are the firmware versions specified? Which versions work with Android, iOS, OSX, etc?

#2 - I only see ‘Update Firmware’ in my applications (iOS/OSX). I do not see where to specify version. And further … updating from OSX (running Catalina) hangs.


#4

1: I cannot confirm because my Codey no longer connects to my iPad but I believe that you have no choice of Firmware.

2: On PC, it’s in the parameter

py

P.-S. Buuugggggg The text is bold and very big … I don’t know why and I don’t cry … sorry


#5

P.-S. Buuugggggg The text is bold and very big … I don’t know why and I don’t cry … sorry


#6

Firmware cannot be updated via bluetooth on Mac/PC. Version cannot be selected on iOS Apps.

And I cannot connect via USB either. I have tried on 3 machines (2 Macs & a PC).

Same behavior as originally outlined. Manual control of robot works via MakeBlock App. MBlock app does not work on anything.

Just dead in the water. Cannot believe they updated firmware to a version that has this crippling behavior.

Kids (and I) now associate Codey Rocky with cursing, cable swapping, software downloads and forum posts.


#7

Ok, I seem to understand better. Are you in a completely MAC environment?

I seem to be in the same situation as you when it comes to MAC equipment. On Android and PC, I have no problem. Before you fly your Codey Rockey out the window, try yourself with Android and PC equipment. I am aware that this is not your first choice but it is to isolate the problem.

  1. MAC and IOS = Not functional?
  2. Android or PC = ???

PS The little robot will be fun. It’s even sad to start this way. With a lot of problems that happen during the Chinese holiday.


#8

I’ve tried PC and it does not work. I do not have an android device.

How does one contact official support?


#9

Hi Rockbear,

You can try the private message. Usually they respond quickly and you have access to the engineers. They always correct my problem and answer my questions.

However, the forum seems dead due to the Coronavirus. Good luck.