Uploaded Arduino Program, Now mBlock App Android Won't Work


#1

Hi All,
Hoping that someone can help me out here. I have the Ultimate 2.0, built the self balancing robot, and then connected it to the mBlock Android app after construction. The app worked fine (connected, controlled robot) with the default single motion control stick when you select the self balancing robot in the app menu. I then created an Arduino program to control the two encoder motors and uploaded to the board. The program works fine, but now the robot won’t connect to the Android app. The bluetooth module led is blue, but the RJ45 module and the austoutic detector module led’s are both red. I downloaded the mBlock3 and mBlock5 windows software and restored the firmware, but that doesn’t work and the robot still won’t connect over bluetooth. I, obviously, downloaded the Arduino github library for the Ultimate 2.0 and uploaded each firmware individually and tried to reconnect to the app; nothing works.

I understand that when I upload to regular Arduino Uno boards the old software gets wiped each time I upload new code, but I thought a $400 robot would have some type of extra protocol that saves the original firmware. Clearly I was wrong. Definitely not going to buy anything from these guys again if it turns out that this is by design.

Again, any help finding the original firmware so I can control the robot through the app is appreciated.


#2

This isn’t by design. If you’ve uploaded the firmware both via the MBLOCK5 and via Github firmware upload , it should reset back to factory default. Sounds like you’ve done everything I would have done, but it’s definitely not by design. Hopefully @tech_support will be along soon to help


#3

Tech support supplied the following advise which did not work for me, but it should.

1.Every robot has its default program when we sell out,this default program makes you can play it once you assembly it well.

2.After you self-programming the programs to the robot by PC,it may change the robot’s original firmware,so when you connect the robot with Android APP,Android APP cannot detect with robot’s original firmware,so it cannot connect properly,here attach the guidance for how to recovery back to original firmware,pls help double verify on this again.

3.For mBot and Ultimate series products,its power consumption is very big,the battery needs enough power while connecting,can you help use new battery to verify it again?