Unbearable inconsistency


#1

I have got 5 ultimate kits and every single one of them has been causing me nothing but problems.

The programs or pieces lacks consistency regarding its functionality.

I have connected the motors to the microcontroller and coded everything properly. I tried for about 40 minutes to just move the robot forward, nothing happened. When the students left, i tried the same thing and it worked smoothly.

Today we have been trying to upload programs into microcontroller. It uploaded once and then the upload did not work for 3-4 minutes. And this problem kept happening throughout the whole lesson like a loop.

We tried to set the robot to move backwards if the distance calculated by the ultrasound sensor is smaller than 3cm. The ultrasound sensors does not recognise any obstacle if you dont press your thumb towards it.

Is there anyone else who have experienced similar tragedies with the Ultimate 2.0 kit?

If yes please bless and enlighten me with your solutions.


#2

Hi enesk,

It seems to me to have already had this behavior with my mBots, more than a year ago.
Makeblock will correct me but the explanation should work for other models.

The problem was that the Ultrasonic sensor seemed to be having problems. It worked my randomly. Conclusion, the mBot was executing the instructions sequentially and my code was not the best.

Did you try a very simple code to confirm that the sensor is not the problem?

This code should work fine.
stop

If this code works then we’ll look at your code.


#3

This is the code that i have tried to run with 3 different ultimate 2.0 kits and it did not work:

a4sd6asda


#4

Hi enesk,

The code is good, I have no solution. You will have to wait for a solution from Makeblock. For now, you can try it live to watch the behavior of your sensor.

Just create a variable