Unable to Upload Code to mBot, timeout error


I have just purchased the Mbot for my kid and he wrote a very simple block code but when we tried to upload we were not able to

here is the error -
Error: Sending 3020: receiveData timeout after 1000ms


Hi Dipteshd,

I have checked the web version as it bugs every now and then, but it looks okay. It is worth a little more information.

Web version with mLink or Local?
PC, MAC, Linux, Tablet?

When you indicate simple code. Did you try the starter block and simply turned on the 2 lights in red ??


It is resolved, i have an old mac so I switched to a PC ,


I have the same problem. I’m using an hp laptop that isn’t very old and I’m trying to upload block code to my mBot, but it’s saying Error: Sending 3020: receiveData timeout after 1000ms. I’m using Microsoft Edge as a web browser. I’ve tried using Google Chrome, but whenever I try connecting a device (mBot) it says Download and install mLink 2 now to connect devices for coding. Even though I already have mLink 2 downloaded, every time I try to connect the device, that message pops up.


Also, I don’t know what these mean, but it also said in red text: mcore.upload_fail_fded06b5


@rackofshad @Dipteshd Did you make sure that Edge can access your ports, mLink is running, and that you connected the bot to the correct port?

mBot Code Upload Problem: Timeout and Code Compiling Error

@everyone see the conversation here before posting:

If it doesn’t resolve the issue, only then should you post here.


Bro please help me I am getting 3020 ERROR 1000ms while uploading codes i checked all things
i made sure mlink is running i reset it by the onboard button by clicking it i am using microsoft edge and
even chrome but it the same error i am using A to B cable for it please tell the solution bro pls


@MINARDI welcome to the forum! Please see the post here:

And try some of those steps.

Is this a standard USB too USB port device connection? What port are you connecting to in the software? Provide some more info or screenshots of your steps, so I can troubleshoot further. Thanks!