mBot Code Upload Problem: Timeout and Code Compiling Error


I’m using an hp laptop that isn’t very old and I’m trying to upload block code to my mBot, but it’s saying Error: Sending 3020: receiveData timeout after 1000ms. I’m using Microsoft Edge as a web browser. I’ve tried using Google Chrome, but whenever I try connecting a device (mBot) it says Download and install mLink 2 now to connect devices for coding. Even though I already have mLink 2 downloaded, every time I try to connect the device, that message pops up. Also, when I tried to upload the code from Microsoft Edge, it also said in red text: mcore.upload_fail_fded06b5

Unable to Upload Code to mBot, timeout error
mBot upload issues on Chromebook, timeout and upload fail
Unable to Upload Code to mBot, timeout error

@rackofshad See here:


I believe that all of these are set up correctly. It was working great half an hour ago, but then I changed the code and tried to upload it again and it is no longer working.


I changed the code a bit and turned the mBot off and back on again and it seems to be working fine now. Thanks for offering help


No problem! Do you mind if I ask what the code that failed was, so I can troubleshoot for others and myself in the feature? @rackofshad


I believe that this would mean that mCore failed to process your code (maybe it has an error?) based on my research.


When I changed the code the first time I incorporated repeat until loops and then it stopped working. When I changed the code again, I did not remove them, I just changed the code inside of them. I think all I probably had to do was restart the mBot.


Likely. Perhaps one of your codes causes the mBot to crash. mCore is mBot’s core processor, so the mCore upload fail errors likely mean that mCore was either not connected, overloaded, or crashed. So, restarting the mBot fixed the issue. Thanks for the info! @rackofshad


I have same kind of error and it says -“Error: Sending 3020: receiveData timeout after 1000ms” inh red color i cant fix it what to do?
i tried everything


@MINARDI Can you send screenshots or a screencast, or more info?

What all exactly did you try?
I’ll try to test some with my device later this week. Good luck!


hey yea let me send u screen shot


the mcore lights are not blinking like normally and some rgb lights are off and the ir sensors lights are off this is not normal cuz i bought this all front lights used to glow like rgb


only red lights are glowing everywhere now which it didnt used to be



@MINARDI What port do you connect to with the software? Have you tried the PC version instead of web? Is mLink 2 on?


I only used the web version cuz whenever i click on create on mlink it takes me to web so not so sure about PC version, the mlink is working fine as u can see in the screenshot, I connected com-4 or sometimes com-5


@MINARDI If you click the ‘Show all connectable devices’ option, then what ports are there available to connect to?


No i checked there are only one. I just wanted to know did, I break the mbot or what?
like it was working fine a week ago and now its led dont glow and codes dont upload
is it a rare problem?


@MINARDI You may have broken it. Did you do anything that might have that you can think of? At this point, without further info, all I can advise you to do is contact support:

Good luck.


I didnt broke anything. I tried to reconnect every wire to fix it but didnt work.


I just sent them a mail about the issue btw what do u think could have gone wrong?