Ultimate 2.0 won’t connect to the app


I have an ultimate 2.0 robot that I hadn’t used since the pandemic began. Today (18/03/2022) I made the robotic arm and was hopping to try it out. But when I entered the app and tried to connect it via Bluetooth, the phone never detected the robot (I tried this with several phones). Everything seems fine with the card. So I was wondering if anyone has an idea of why it may not be working?

Thank you


Hello Mai

It may help if you try unplugging the Bluetooth module from the Megapi board and then pluging it back in again. The phone app is usually very good at detecting a bluetooth signal.


As you suggested I unplugged and plugged the Bluetooth module, but it still won’t connect to the app. It has a blue light turned on, is the light supposed to be blue? Is there anything else I could try to fix these problem?


If it’s working correctly then a blue LED on the innermost corner of the Bluetooth module should be flashing slowly (in sync with another blue LED in the centre of the MegaPi board…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.