Starter/Orion Firmware Update problems


A similar post is closed at

I have a few Starter Bluetooth version kits that I’m putting together with my son. They say I need to do firmware update first. Android and Ios apps say use the PC app. OK, I got Windows app 5.4. That didn’t completely install on one computer, some error about the USB serial driver part. Another computer seems to have installed all the way successfully. I have seen some tings about a Starter 2.0, I don’t know how to tell if this is that or if this is 1.0. I had bought them some time ago when Radio Shack was doing clearance sales, so they are some years old, I am just getting to doing something finally.

Now, in Windows app 5.4, connect seems to recognize something is there, but the firmware udpater calls it CyperPi, not Orion. I don’t seem to be able to change the device to Orion, but I see in some other posts that the firmware udpater says Orion as the device name. I tried letting it do what it brought up, with the CyperPi name, it went to 20% and failed and stopped there.

I’m about to try again with Windows app 3.4.12 and see if that makes any difference, but it seems it needs me to reboot the PC first. Ugh. After that I may try Web/Link and see if that helps or not.


Using Windows app 3.4.12 did a succesful firmware update. I noticed there to choose the board in use/connected and selected Orion. I don’t know what version of firmware that gave me.

Going back to 5.4, Ah, on the left is an Add Device icon, and I added Orion, selected that, connected and did firmware update from that. This gives me a choice of factory version or latest version firmware, I chose latest. This goes to 51% then fails. Doesn’t say why, but I’ve tried a few times. I do have buzzer disabled at the tiny white switch on the board.


The app sometimes reminds to disable the buzzer before uploading, the tiny white switch. That didn’t get us to good yet. At some point we saw something elsewhere about disconnecting the bluetooth module to upload, and now I have updated firmware successfully in 5.4 to latest firmware version.

I wish the documentation and app hints were a little better at guiding us through these things…

Do we need to have buzzer disabled and bluetooth disconnected in “live” mode as well, like seems needed for “upload” mode?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.