Starter Kit Basic Questions, Please Help


Hello, my wife and I bought our 10 year old a Makeblock Starter Kit IR version for her birthday and I am having serious trouble making anything work.

  1. I have a MacBook running Sierra 10.12.2
  2. I have mBlock version 3.4.5
  3. I was able to connect the robot to mBlock and update firmware.
  4. We have been trying to write code but none of it seems to work. We found a post in the forum about how to program using the remote, so we tried this:

This is exactly the same as the post we looked at. We were able to download this program to the robot but it didn’t work right. When we pushed forward it turned, or some of the buttons didn’t work at all. Can someone please explain to me (pretend I am three so make the directions basic) why this doesn’t work?

Also, can someone explain to me the boards option in Makeblock. I understand different robots have different boards. I thought the correct option for our robot was starter/ultimate(orion). Do I always need to use the Orion Program block before any program? Thank you for the help. I can’t wait to finally understand the basics and get to more advanced stuff.



Start with a fresh set of batteries. Make sure that the motors are connected properly. The program should work. If it turns in the opposite direction as expected, you could switch the motor connections (i.e. M1 for right motor, to M2 for right motor).

As for the board, yes you should use the starter/ultimate(orion) and Orion Program for any code that you want to put on the robot. Each board is different based on the number and type of connections or features on the board. The different program options are setup to insure that ports work properly.

Let me know if this helps.



Well, good news and bad news. I took the robot apart and rewired it. The program below now works. See picture:

Notice I had to recode a few pieces also. When I download this code if I push forward on the remote it goes forward, backwards, goes backwards, etc…

I should mention the directions for the kit are not as clear as they could be…

However, I still have a problem. I tried the following code, which I found on a youtube video to test the sensor. It doesn’t work at all. The tracks don’t move, nothing. Is the code wrong?


Distancefromobject is in centimeters. So the if statement will always be true unless you are closer than a few millimeters.

Just try the following if statement
IF distancefromobject < 5



Try inverting the fraction, distanceFromObject / centimetersPerInch.



I definitely thank you for your help but apparently I spoke to soon about the previous program working. Here is my problem. I did get the previous program to work when I switched a wire on one of the motors. Everything worked %100 according to the program HOWEVER, on a whim I decided to load the default settings back on the robot AND THEN the remote did not work correctly. Yet again, I changed that wire back and the default settings worked %100 BUT that program above, with the directions did not. IN ADDITION, I tried this very basic program to try to trouble shoot:

When I tried this program one track went forward and the other track went backwards. Now I am totally confused. I assume if the default program works properly than the wires are absolutely correct. If the wires are correct why is nothing working as it should?

Also, the M1 motor is the one going backward, M2 goes forward. I did also notice, after looking at the directions again that M1 and M2 motors are reversed on the slots on the board, but since the default program works fine I have no idea if this makes a difference or not. When I did reverse them to the other slots the default program didn’t work right.



@Arram has come up with an interesting problem. Please see if you can help in this situation.



After looking at the robot again everything is %100 correct. The motors are plugged into the right ports, the default program works fine BUT when I use that simple program to make both motors go forward 1 motor goes in reverse. Yes, I can switch the wiring and that would solve the problem but then it messes up the default program. I am at a total loss now.


Hi mddickey,

Please see this post which is figured out by other users:Makeblock You are about to lose a customer