Nervous bird part of the Ranger


I have tried to update firmware with pc software and it don’t work. The only option I have is the online firmware not factory. I’ve replaced batteries and checked all connections but when I start it up, the wheels just spin like there is a program running. Is makeblock 3 an option? I ran the Ranger configuration with no problems. I need help.


Have you tried the dropdown menu on the update to see other options? Try uploading your own code to it too. @jimbo1


There are no options, the firmware update is the only the online update, no factory update


Try uploading your own code. Do you have screenshots? What device in mBlock are you using? @jimbo1


I’m using the ranger, I uploaded some code and ran it but the motors keep running. The thing is, the nervous bird ran earlier, I would run it once and the next time the motors just run. I tried several times to run the firmware but no results.


The online firmware is the latest firmware for mBot Ranger. There is no default code that mBot Ranger comes with, if that is what you mean. If you want a code for the nervous bird, you will have to make one.


Sorry that was a bit late.


Have you tried say unplugging the motors and such? I don’t quite understand your problem.


I unplugged everything, no good


Strange. Maybe it is a hardware issue.


You can contact mBlock


I’m going to set up the ranger again and try that, maybe it’s a gyro problem


Maybe. Do you have a specific nervous bird code, or is this the app?


It’s the app. I just notified support, so we’ll see.


Yes, the app has trouble.

I use the PC version.


I’m new to all this, but I’m very careful about how I put this together, and the ranger worked fine.


Yes. It is trouble with the app. Not your fault. :slight_smile: I hope you get them to fix it. I’ll contact them, too.


Glad to here I’m not the only one having a problem.




But yes. You can try to make a code on PC for it.