Need help adding device without Internet connection


our LAN is not connected to the internet and each students have their own log in account (domain account). I noticed that every student who will log in and open mBlock, they need to add the device (mRanger), but they can’t add any device if there is no internet connection. Is there a way to add a device without connecting to the internet?
BTW, I installed the PC version of mBlock 5.4.2.



If you can connect to the internet for a short time, then you can download the device by double-clicking on it and use it later (in the mBlock PC V5.4). Else, you can manually add the device to each computer, which is not easy.

Problem adding device

I have tried this one and yes, it will work but the problem is, this should be done for every user/students since they different account.


When you say do it manually, there is a file that I will download and where can I get it?


You have to do the file manually (e.g., from a thumb drive) for each student device too, but I can private message you the file to mBot Ranger if you need it.


I drag the file from thumb drive to the device tab of mblock. It just say succcessfully updated but I can’t see the device added.


It doesn’t add it. It updates it, so you should be able to go to the device list and add mBot Ranger from there.


Aftter updating, I selected from the device list mBot Ranger and still, it doesn’t allow me to add it.
Note: The PCs are offline.


Hmm. I don’t know why this would happen. If you can put the PCs online temporarily and download mBot Ranger by clicking the “+”, that would be the best thing to do.


Still looking for a solution for this problem until today.


I do not understand why that is not working, for me, it works perfectly.


I tried installing the latest version 5.4.3 and still it’s not working but when I tried installing 5.4.0, it works perfectly. I don’t know if it’s a bug or they just really made it online starting V5.4.2.

In case, I’m just thinking that if you added a device before, delete it and add again (offline) it will already work (I tried doing this).


OK, I guess use the desktop version V5.4 then. :slight_smile:


Yes, it is big problem here, in Turkmenistan, cause makeblock websites are blocked here, don’t know why. So, App can’t reach it’s source in the internet, and only VPN connection can help us. It would be perfect if makeblock will publish some files for offline usage, to download them and add to local installed mBlock.


I’ll contact mBlock and see what I can find out.


Same problem here in Belgium today. Adding devices in 5.4.3 local PC version is not possible. 5.4.0 works without a problem. I noticed that my 5.4.0 projects do run in 5.4.3. When I load my scripts for 5.4.0 that include some devices, and open them in 5.4.3 then the same devices are already loaded.

So my current workaround is to make a project in 5.4.0 and add the needed devices. Safe that project in a local file. Open that project in 5.4.3 as starting point for the coding exercise. All devices will be available.

Starting a project in the on-line mBlock5 , adding the needed devices, and saving it locally also works, when the *.mblock file is loaded in the local version.

I suspect 5.4.3 to search at the wrong internet location (URL) for device files.


@everyone @bpwl @lakay The issue does seem to only occur in 5.4.3. For now, as there are no new features in that version, I just downgraded to 5.4.0 and use it instead.


I see connections to . Are those having a problem?

{“code”: 0, “message”: “Success”, “data”: {“message”: “Welcome to MakeBlock.”, “version”: “6fdb9341c74ad9fb7db4ede99b130b469dc18b08”}}


Nope! That’s a JSON response from the makeblock API, and it looks fine. Code 0 is success.




The other connection made when a new device is loaded in 5.4.3 , is to https:// , I have no content for this one.

Well should compare with 5.4.0 … but https is not that easy to analyse, needed “Fiddler2 app” as intermediate proxy to see the encrypted content.