Motors 1 and 2 are always rotating (Ultimate 2.0, mBlock 5)


totally new user and not experienced coder - put robot arm together used iphone app - great
wrote some code with mblock 5 that worked well with usb tried to hook up dongle - code did not work - nothing happened

went back to usb interface now motors 1 and 2 just run nonstop can’t even shut them off with code

updated firmware on iphone and aslo through makeblock still no fix
saw a post from 2018 with similar problem do I need to erase the eeprom ( ie learn how to use arduino c) or is ther something easier this is VERY FRUSTRATING FOR A NEWBIE to figure out


See my comments on my recent post (link shown below):


I went live and just put simple command for all motors to run at 0 power but they kept spinning
Tried opening 3 different programs in live mode I had run very successfully for days and none would stop the behaviour or run properly I then unhooked motors opened new blank files several times added the ultimate 2.0 Download updated the firmware added one simple command (set motor powers to 0) and still the wheels on motor 1 and 2 will just keep going nonstop the iPhone app won’t work with it either so…… may just spend a week learning arduino c and try to just bypass the whole Makeblock block code unless someone can point me in right direction thanks CommanderR but can’t link to a related post you wrote for some reason


I found post from v106 in Feb of 19 describing identical problems that they only solved by wiping eeprom but not sure I understand how eeprom gets corrupted to do this in the first place and how it actually interacts with firmware updates live mode phone apps etc is there any documentation about how all that works ???


@superman17 See @CommandeR’s post, and also, do you have any photos of your setup? Try uploading a code that stops the motors forever to the board. I’m not sure if resetting the EEPROM would be a good idea, but you can try. Of course, also reset the firmware (re-upload it in from mBlock 5.4.0), and reach out to makeblock support:
Also, can you please provide the link to the post you found? Thanks, and good luck!

Feel free to ask the mBlock AI questions as well (mistakes are likely and information is unverified:


Have you tried connecting the motors to the encoder driver boards on ports 3 & 4 and not the more usual ports 1&2 ?


Also try the web version at


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.