Mbot with mblock5 bluetooth on windows 10 broken for "live" mode


This is for bluetooth. I have tested on two windows 10 machines which are Bluetooth 4 and LE compatible.

Am having issues using online mode with mBot and mblock 5
Using version 3, I can use scratch/online mode fine.

With version 5, when I connect to Bluetooth (->Makebot_le from memory), I delete the codey and add an mBot. I then create a when flag is pressed, move forwards 1 second at 50%
When I press the green flag, the code flashes, and then an Update firmware flashes up.
It won’t allow me to update the firmware over Bluetooth - OK.
I disconnect, insert USB, connect, click settings, firmware update, update to online …. 107 (or something). It uploads OK
But when I go back to Bluetooth mode, same problem, firmware update required.

It looks like others might have had similar issues but given up? Any ideas, or do I return this as not suitable for my needs?


I’m having exactly the same problems with both an mbot and the ranger as well.

Not happy about it.



Please tell me the details of the version of mblock5. (Example: v5.0.0)


The about says v5.1.0


hi all,
I just tested my windows 10, it works as it should be.
Will you send me a video to show the whole process (update firmware with usb connection-connect with bluetooth-requires update again)? You may send it to stephanie.wu@makeblock.com via https://transfer.pcloud.com/
Also please provide us your computer mother board information and the bluetooth version information.
We will try to have a check.


I have tried this on two different computers. One is a Surface Pro 3 from Microsoft. This I have installed mblock 3 and mblock 5.1 and only the 3 works.
The second machine is the Surface Book 2 15" from Microsoft. This has only had the mblock 5.1 installed.
The symptoms are the same. The BT driver is the latest available (online search+windows update).


I have tried both from a factory default (again, both as the mbot was delivered, and with a reset to factory default firmware) and from the mbot 3 version firmware (which works Bluetooth mode with the version 3 mblock).
The video will be with 06.07.107 installed
Connect via USB ad update
Unplug USB, turn off
Turn on
Select connect via Bluetooth
Press green flag and it changes to show an update is required
Update can only be performed via USB

mBlock 5 Bluetooth version

May I know when did you purchase the mBot?
Is that your Bluetooth module is one of below?



It was ordered on the 1st June 2019, was only delivered 5th of July.
The Bluetooth module is similar (the sub-module doesn’t have ANY lettering that the picture above does, the large chip is novoton) to the top picture.


Could you show me your Bluetooth module picture? According to your description “the sub-module doesn’t have ANY lettering that the picture above does, the large chip is nuvoton”, I am afraid that is not Bluetooth module.
In another post, you mentioned you need update with usb again and again, may I have the video?


The video was uploaded using the pcloud file transfer as requested 3 days ago.
I will be very disappointed if this is not the Bluetooth module, as it was explicitly that version I ordered. And that the module connects via Bluetooth with mblock3, and pairs with Bluetooth, etc. etc. , and works as Bluetooth connected with mbot 3.

Adafruit mBot Robot Kit - Bluetooth Version [ADA3640]
Attaching images doesn’t appear to be working properly today




Sorry, I didn’t receive the video, could you send me again? stephanie.wu@makeblock.com


Is it a Bluetooth module?
I will start the upload again, but the previous one took several hours to upload.

Given that I have described quite clearly the issue, do you have an idea what the problem is?
I don’t think it can be a hardware issue, as it obviously works with the older software.


Finally uploaded


I’m sorry I feel that the image above also has a nuvoton mark.


Yes, I believe the chips are the same, but the blue sub-module doesn’t have the same silk-screen writing.
So at a minimum a different batch, possibly a different layout.


I can see that the video was downloaded. any progress?


Hi, any updates?