mBot Ranger Land Raider not moving


Recently I bought an mBot ranger and assembled the Land Raider, but it doesn’t move. I already changed the batteries, but it still doesn’t work. Only the right track/motor of the Raider is moving when I did some tests.
Is there any solution to the problem?


Do the motors turn freely without the wheels being attached to them? If they do, then slacken offf their retaining screws and reposition the motors very slightly. See my previous post on this at:


Sorry, whilst the above is applicable, I meant to refer to this link:


I can see that I’ve posted the same link twice - Sorry about that - I blame it on post-COVID ‘brain-fog’.

When I ran my own Ranger for the first time using the Makeblock App, one wheel ran much slower than the other. But why?

The 10mm dia. stepped hub on the inside of both 62T wheels rotates in the end- hole of the Makeblock 61410 plate-135º components that make up the sides of the chassis. This hole is 10.2 mm in diameter (and as such, has enough clearance for boss in the centre of each wheel to revolve freely) - but not if the motor’s axle is not centred accurately over the centre of each hole.

This was easy to fix by removing the rubbing wheel from the axle and slackening the two screws holding the motor onto the inside of the plate. There is enough ‘play’ in the 4mm holes in the plate to allow the screws to be moved slightly and retightened allowing the axle to be repositioned centrally. After this minor readjustment, there was now friction between hub and hole and the model worked perfectly.


Thank you for contacting us.
This is Max from Makeblock Technical Support Team.
According to your description, we preliminarily infer that the screw of the wheel is too tight. But in order to locate the problem as soon as possible, please send the operation video to our after-sales team ( support@makeblock.com ) for troubleshooting.

Best Regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.