Problem motor MBOT ranger


when I make code for it to advance, they advance in small spurts. It is very annoying because it is not fluid and not fast. he advances a small step of barely a millimeter then he pauses

mBot Ranger Land Raider not moving
mBot Ranger Land Raider not moving

It has been frequently reported here that Ranger wheels often stick and prevent the model from moving or the robot not driving correctly. A fault often dismissed as being caused by low battery power. This happen to me, with just one of the free-turning wheels and it was NOT battery power related. After several tests I thought that the problem might be something to do with the recessing of the central hub of the wheels to allow the bushes to seat inside them correctly.

I worked out that the holes through the two bushes on either side of the wheel were in not quite the same alignment - but how was I to ream them out as if they were one aligned unit?

My solution to this was to mount a wheel with two bushes on to the threaded part of a short spindle and loosely secure it with a Nylock locking nut. I then put the smooth part of the spindle into the chuck of an electric drill and turned it on (for about a minute) whilst I firmly held the on to the wheel!

This meant that the threaded part of the shaft was revolving inside the two bushes (which, remember, were assembled in true alignment with each other) - so, would the thread act as a simple abrasive device to free-up the wheel and allow it to spin freely?- YES it did! - and with a bit of wiggling of the wheel (to improve the abrading effect of the threaded shaft spinning inside the bushes) it did seem to work very well. Success, everything now worked OK!


I will test, thank you


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.