MBot Ranger - BRAND NEW - Bluetooth drops CONSTANTLY > Full frustration and disappointment - HELP!


#1

Dear all,

I have lately bought for my little son, a BRAND NEW mBot Ranger (serial number in the photo below) and I experience major issue with the Bluetooth connection that fails constantly to work properly, leading -as you may probably imagine- to a major disappointment to both himself and me (for choosing such product in the very first place)

As you may see below, I have even tried to troubleshoot the issue myself, in order to understand better the issue, but unfortunately even if I figured out that energy is not the issue, I couldn’t find a proper solution.

Having also checked online on forums, it seems as if this is an issue that many are facing but remains unclear if there is a solution on this.

I would therefore appreciate ( not to mention require from Makeblock’s tech team and for a premium product like this) some clear and direct response on a working solution!

I really hope Makeblock as the manufacturer of this product could provide me -as a customer- a clear solution to this problem which really lead me to frustration and compete disappointment of this product of the product purchased.

In detail:

  • The problem is that even though connection is established, I experience Bluetooth drops in connection.

  • I have installed on all three devices I have available

That is:

iPad air, iPhone 11 Pro Max, ipadPro 12.9 -all using latest 15.2 iOS and ipadOs version)
Nexus 5 (Android 6.0.1)

For all the above by installing the latest version from respective appstores (3.9.0 for iOS, ipadOs AND Android as you see from the screenshots below)

  • I also made sure the firmware is updated to the latest available 09.01.017 by connecting the board using usb and installing it through Makeblock’s windows version.

  • In order also to ensure that batteries or in general energy level is not the issue, I have tried to check the behaviour using both batteries AND by plugging in an ordinary 12V plug cord power supply into arduino board as shown below.

just for reference:

( BATTERIES: I have installed brand new Energizer’s AA 1.5V batteries into the system as shown below)

image

image

(POWER SUPPLY: 12v power cord supply as shown below)

image

UNFORTUNATELY the issue STILL persists.

Bluetooth connection STILL drops after a while (it’s just that with the cord it last just VERY few seconds longer, but apparently nowhere near what one would have expected.)

  • VIDEOS
    In order for you to see the issue I have even uploaded small videos of each case on Dropbox below:
  1. Behaviour using 6x 1.5v Energizer batteries as shown above:
    https://www.dropbox.com/s/cw5pqezy3rnknr5/FailOnBatteries.MOV?dl=0

  2. Behaviour using 12v plug as shown above:
    https://www.dropbox.com/s/og9oherb50npzoe/FailOnPlug.MOV?dl=0

So even if I could understand that Makeblock recommends using
rechargeable Li-ion battery or rechargeable nickel-metal hydride, nickel-cadmium

EVEN with the brand NEW Energizer’s batteries ( which are still recommended by Makeblock), Bluetooth connections constantly drops!

AND REALLY STILL, having 12v DC cable connected power supply still end up with constant Bluetooth disconnections.

To me that’s shows in practice that power supply is simply NOT the problem here.

NOTE: I get same disconnections by both using the virtual joysticks to control the device (as shown in the videos shared above) as well as when running code through the mBlock Blocky application!

That all makes the use of such device for education purposes pretty USELESS.

  • Not sure if that helps you identify the issue, but please find also below the serial number of the Mbot package I bought brand new:

image

I really hope you may understand my complete DISAPPOINTMENT and FRUSTRATION I feel as a customer experiencing such a major issue from a brand like Makeblock.

PLEASE HELP

I really remain at your disposal for any additional clarification needed and

I am looking forward to receiving makeblock’s tech team response with hopefully a clear direction with an absolutely working solution that gets such major issue fixed once and for all.


#2

Hi Tristratos,

I understand your disappointment because the RANGER is still a little more expensive than a small mBot. Personally, I have never had such a problem and still have a few bots. Your relentlessness is fine but maybe it is just a problem with the bluetooth module.

Did you try to remove the module, check the status of the PINs and put it back?
2022-01-09%2015_57_49-Window

Makeblock doesn’t work on weekends but they should respond this Monday. Make sure to do this test as I have never had this problem and especially with a distance like yours.

Good luck, there must be an explanation because bluetooth usually works fine.


#3

Dear Crackel,

Thank you for your suggestion.

I would still though wait for an official response from Makeblock as I wouldn’t like to damage the solution myself (also meaning that I would need clear instructions of how to open the plastic shell without damaging it, in case this is indeed something I should do or should I just wait for a total replacement instead)

A formal response from Makeblock’s tech representatives would be highly appreciated.


#4

Hi Tristratos

Like Crackel I’ve not had ay problems with Ranger - either with the Android App or with mBlock on a PC - sadly, I have no experience of using Ranger with Apple stuff and have not seen your version of the App before. However Crackel’s idea of removing and replacing the Bluetooth module is not a bad idea so I have attached below an image of a couple of pages (onn how to open the protective shell) from my forthcoming book on Ranger:


Bluetooth/Phone App not working
#5

@ Makeblock’s tech team

Is that indeed what I should do?

I don’t want to brake anything and be liable for damages of a new product that due to its faulty behaviour needs to be picked up and be replaced directly instead.

Please advice!

P.S. seems I am not the only one complaining here lately…


#6

Also another post on the same issue lately

It really seems at least strange receiving a response to my ticket (25798) at support.makeblock.com from the support consulting me to use 18650 Li-Ion battery pack instead of Energizer batteries when:

  1. In the mR\Bot Ranger manual it says “1.2v rechargeable OR 1.5v alkaline batteries Like Duracel/ Energizer batteries would do”

  2. I have checked as stated with 12v cable power supply and issue still persists.
    How would 18650 li-ion battery pack would have ANY difference at all?

Please correct me if I am wrong, but seems as if the support team either use default responses to answer or doesn’t take into account the feedback shared.
To me the above shows that the unit received is simply faulty and buying any other battery type that would practically replicate the same behaviour as the one I get using the DC cable of 12v power would simply NOT solve the issue.

If that is indeed the case Makeblock needs to replace the item received from Makeblock’s own Amazon store ASAP.

Am I so wrong? If so PLEASE DO EXPLAIN WHY

@Makeblock’s tech team
Otherwise please provide a clear SOLUTION to this apparently common issue!

I am really sorry for being that frustrated, but the messages (or the lack of a clear one) from Makeblock that simply ignores me (and seems rest users) for such a common it seems buggy behaviour is really unprofessional the least!


Random disconnection of mbot Ranger
#7

Hi Tristratos,

Did you try to use 18650 Li-Ion batteries? :joy: I was joking a bit because you seem to be going around in circles with the medium. It is difficult to excuse this type of response. So far and in general, I have always received very good service from Makeblock but I also admit that I have a lot of kit to test and that I am not afraid to destroy everything.

For the batteries, Alkaline will be correct (Look no further).

For warranty, I would do an Amazon replacement with permission from Makeblock or Amazon. Ok, I just lost my chance to get a free or less expensive mBot 2 to help you out but there are limits to going around in circles.

Personally, I would follow CommandR’s instructions and remove the bluetooth module. The module seems loose or it is the module itself that is in problem. It’s not that fragile and since it doesn’t work, it can’t get any worse. Beware of static electricity, otherwise you should be fine.

It is also a good idea to wait for a response from Makeblock. They have more information, like there’s a general problem or it’s only a few units.

I’m sorry for the problem as this is not usual on Makeblock products.


#8

@crackel - thank you for your reply (I guess you understand that I am not the one being me being illogical here…)

@ Makeblock’s tech team
Is there any precise instruction on how this should be fixed OR should I simply return unit to receive a replacement?


#9

Hi there:

Please check the parameters below and follow the instrusction to fix this problem.


#10

Sorry to say but this really gets more frustrating.

@makeblock.lindingxin
WHAT ON EARTH am I supposed to understand from the above image?

I tried BOTH

BOTH have SAME FAULTY result - that is Bluetooth DROPPING after few seconds of use!

WHY and HOW 18560 batteries would bring ANYTHING difference?

In the meantime as this was bought directly from Makeblock’s store on Amazon.de, I am allowed to return eligible until 8 February!

COULD ANYONE FROM @makeblock ANSWER ME ON THIS OFFICIALY AND RESPONSIBLY ?


#11

Hi:

The stable working voltage is DC 6V-12V and minimum working current is 2A,it means your batteries group have to output 12W power even higher power stably,obviously regular AA batteries are not ideal,18650(2600mAh) is a better option,the discharge process of the battery is not linear, but will gradually decay during the discharge process, so the 18650 battery with a larger capacity is the first choice for driving a high-power robot like the mBot ranger


#12

I really have hard time to understand this - but even if that was the case, WHY on earth Makeblock does not REQUIRE such specs by default !?

As you may understand, to me this is frustrating and shows that something is totally wrong here.
Something that I would certainly wouldn’t from a brand and product (not tomention price range) like this!

I really hope @Makeblock provides me with a proper solution to this whole mess


#13

And I noticed that you have used the DC 12V to connect with ranger directly,did you adjust the current to 2A?if not,it might damage the mainboard mistakenly,


#14

DC was only used for the video recording to showcase the faulty behaviour.

I really hope @Makeblock officially, reliably and responsibly revolves this issue


#15

Hi:

Our official suggestion for ranger’s user is to use 18650 or other lithium batteries rather than arkaline battery。The reason is very simple, because the power of the ranger is relatively high, and the alkaline battery will decay after a few times of use, causing the ranger to not work properly. I believe this is also common sense. At the same time, the input of lower than normal power may also damage the bluetooth module, so far we have had a lot of such cases, it is really disturbing


#16

@makeblock.lindingxin
It is a bit unclear if you are representing Makeblock officially here.

Sorry to say, but same issue happening to many customers all around the same period seems not a coincidence to me.

All apps installed are the final versions as indicated in my other link.
On support ticket Makeblock suggests indeed 18650 batteries to be required (a prerequisite that is mentioned NOwhere else as being the only option which really makes me wonder WHY)

They offered to send such charger solution to me (which is a plus for Makeblock)

That being said, I still do not know if that resolves or not the issue BUT I need a responsible verification from @Makeblock that if that does not resolve the problem and deadline of return on Amazon passes (8 Feb), the unit willl be replaced with NO additional costs from my side or any delays from Makeblock


#17

Hi makeblock.lindingxin,

I was convinced that the problem was not with the batteries.

I changed my Alkaline batteries for my mBot and the Bluetooth connection is super stable.


#18

What is the max current that your DC adapter can supply? Since it seems that for some reason the board resets when motors gain certain speed.


#19

Hi Crackel:

Your are right alkaline batteries is ok for ranger and the key point is alkaline batteries have power attenuation,so we suggest to use the rechargeable lithium battery to replace the alkaline batteries after using several times.