mBot 2 doesn't move anymore after updating the firmware



I have bought a Mbot2 and got it running today with the “Joystick Demo program” and also with the App on Android.
Afterwards I installed the mBlock program on Windows and it offers the possibility to update the Firmware. The first try of the update failed but the second one was successful. Unfortunatelly the Mbot2 doesn’t move anymore afterwards. Also the light that represent the eyes and the sensor to the ground doesn’t light anymore.

What I already tried:

  • upload a new firmware -> doesn’t help
  • reset the Mbot through the menu -> doesn’t help

Does anybody know something else that I can try to fix this problem?
Thanks a lot.



After updating the firmware, the current program is erased. The demo codes should still be there. Try uploading a simple code to make the mBot drive forward or light up and see it works, @FinalD


@Best_codes: Thanks for the answer.
I tried to create program that:

  • writes a text to the display (works)
  • change the light below the joystick to a specific color (works)
  • drive 10cm forward (doesn’t work)
  • change the light below the joystick to a different color (works)

But it looks like that it tries to execute something because the next color change after the “drive” is executed a little time later. If I choose a longer drive (e.g. 30cm) the color change needs more time.

As written also the demo program where I can choose different directions and the Mbot2 starts driving after confirmation doesn’t work anymore.


Hello. I’m having the exact same problem. It was working fine, until I did the firmware upgrade (first time failed, second time worked). I tried to upload one of the demo codes. I can see that i works as it displays what it’s supposed to but it does not move when it’s supposed it. Just like @FinaID, the eyes and ground sensor are no longer working.


@FinalD @pbcampeau Are these programs being run in live mode, or is the code uploaded to the mBot and then the mBot turned on and the code automatically ran? Also, you are both using the app, right? On what device? Good luck! Mention me as @Best_codes, I’m going to go do some troubleshooting with my own mBot. :tada:

My version is 44.01.011. What is yours?

Also, please make sure that both motors are connected. Try uploading the driving code, then turn the mBot off, plug in and unplug the motors well to make sure that the connection is fine. Then turn the mBot back on. I’ve had to do this a couple of times before.

P.S. Welcome to the forum!


Thanks @Best_codes. Interesting! I’m on 44.01.005. It doesn’t want to update to a newer version via USB but it does find a new version by wifi but it keeps failing to connect.

To answer your question, I’m uploading my program, not using Live mode.


You have to make sure that the mBot is connected to Wi-Fi to do the update on the board. You can upload a code like this one:



@Best_codes: Thanks for your help.
For the programming I used the Windows installation and uploaded the code (NOT the live mode). And yes the code automatically run. I also tried to reboot the MBot2 and selected my upload program but the same result: everything works excpect the driving forward.
For the demo program I have choosen “demo 3” direclty from the menu on the MBot2 (this is the demo program where I can choose different directions and after the confirmation the MBot2 executes the selected directions),
Also with the Android App using “Play” where I should be able to drive doesn’t work anymore (it worked before the firmware update).

My firmware version is 44.01.011.

I will try your suggestions tomorrow (here it is after 10 PM).


Now I will check out the console on my mBlock IDE and see if the update thing is an error. What version of mBlock are you using? And is this App or PC? Thanks!


Of course! Have a nice night!


My firmware update works fine. I see this:


Which is the latest version. I’m using mBlock version 5.4.3 on Windows 7 and 11.


After updating the firmware, I upload this code:


Which did not make the mBot move. :frowning: So this is a bug in mBlock which I will have to report @pbcampeau @FinalD. In the meantime, I recommend that you downgrade to version 5.4.0 as it is a stable release with very few issues.


I hope this helps you. I’ll be gone a minute while I report the bug. :slight_smile: Good luck!


@Best_codes: I was curious and checked your suggestions but it didn’t help. I tried to unplug and plug the cables for three times.

The firmware update also works fine for me but as written it failed at the first try and afterwards the movement and the eyes don’t work anymore. Only the display with the coloring still works. I tried to update the firmware two times but this also had no effect.


See my post above (if you didn’t) @FinalD. Good evening and merry Christmas!


It overlapped with my answer. I downgraded to 5.4.0 and updated the firmware again but unfortunatelly with the same result: the MBot2 doesn’t move :frowning:.

Also Merry Christmas :christmas_tree:.

Now I’m really out for today.

//Edit: can you forward the ticket number, please. Or isn’t the bug tracker pubic accessable?


The bug isn’t public right now. Sorry. :confused:


@Best_codes. Using the web version, I was able to get to 44.01.011

Before that, I was using the Windows app (v5.3.0… for some reason, that’s the version that installed by default). So at least, that’s resolve. However, it still doesn’t make my mbot move!

I uploaded this very simple code from the web version:

When Button A is pressed
move forward at 50 rpm for 1 sec
print Done

After uploading it and executing it, I get “Done” on the screen but no movement. It’s clear that the CyberPI works fine. The issue seems to be the communication with the mBot itself, which could also explain why the front sensor light are not lighting up.

Thanks for your help! :slight_smile:


No problem! I’m glad we’ve been able to at least find some bugs. Hopefully you can find out why your cyberpi isn’t communicating. I don’t have many tips there. Good luck and merry Christmas! :christmas_tree:

@pbcampeau @CommandeR


@Best_codes, @pbcampeau I finally got it running again. What I did:

  • uninstall mBlock 5.4.0
  • install mBlock 5.3.0
  • start a firmware update (as previously the try failed)
  • start a firmware update again (this time it worked)
  • disconnect MBot2 from USB
  • turn off MBot2
  • turn on MBot2
  • now the “eyes” lights blue, also the sensors to the ground are on again and the test program to move the MBot2 also works

I don’t know why it works again now but I won’t install 5.4.3 until you closed the bug. I’m happy that it works again :smile:.

The only disadavatange currently is that I cannot change the language of mBlock 5.3.0 (it is currently English and my daugther cannot really read English very well :frowning:).

@Best_codes: Thanks a lot for the quick responses.


Hopefully they will have more translations soon, I’m helping with that on Crowdin. What language does your daughter read well that I can help with?

@FinalD No problem. :slight_smile: I’m here to help.

As for me, I use 5.4.0 with no issues. 5.4.3 is the one I have issues with; but 5.3.0 works fine, too. I got a response from makeblock, as follows (@pbcampeau):

Hopefully, the bug will soon be fixed. Good luck, @everyone, and happy coding!


My daughter can only speak German. But I found out that the web version already supports the translation to German.

Regarding the issue with the moving: I also updated to 5.4.0 and it still works.
Looking at the screenshot: my image on the left side is different because I have the image of the CyperPi and not the image of the mBot Neo? But anyway the posted program also works for me with mBlock 5.4.0 installed on Windows 10. And also the web version works with the simple program.