mBot 2 doesn't move anymore after updating the firmware


@FinalD So is this solved for you or do you still need help? @pbcampeau See what FinalD did and try it yourself, too, please. I received manual instructions from mBlock which I am not allowed to share, I’ll try them myself soon and let you all know how it goes.


@Best_codes: The issue is solved expect that it doesn’t work with 5.4.3 but this will be handled with your support ticket?
Thanks for your help :+1:.


@Best_codes and @FinalD. All good! I did something similar. It wasn’t working at first, so I downgrade to version 5.2, pushed firmware and then used the web version to push the lastest firmware and it worked!

Thanks for your help!


@pbcampeau @FinalD Yes, the support ticket is handling that issue. Glad you have a workaround! :slight_smile: I’m glad that we have some working solutions. I’ll adjust the topic to solve. Thanks for troubleshooting!


Dear all,

I exactly followed these recommendations, … but the mBot2 still doesn´t move. LED´s in the back, sound is okay. The blue LED´s in the front do not switch on when the mBot2 is switched on.

I tried with mblock 5.3.0 and 5.4.3 and have the probleme with both versions. Version 5.4.3 loads a newer firmware compared to 5.3.0. Anyway, the same problem in all 4 possible combinations-


@EdwinK I think mBlock may be updating the firmware to resolve the issue now. Contact them about it personally here:
and they should send you instructions with private files (don’t share them!). Be sure to tell them what you need and send them a link to this from topic as well. Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.