mBlock5 NO WIRELESS MODE for 2.4G mBot


#1

Hi, I am a teacher with a set of mBot 2.4G version. The 2.4G just works a treat. I have downloaded the mBlock5 and shocked to find that there is no way of connecting to our mBots in wireless mode!

I hope you will put this in soon? Also, we have existing .sb2 files that our students have spent a lot of time making a lot of very cool programs. Can we open them in this new mBlock5 environment?

Thanks,
PH.


#2

Hi Petet,
I am afraid there is no plan to support 2.4G currently. You may use Bluetooth dongle+ Bluetooth module or USB cable.


2.4 Dongel is not working wth Mblock 5
#3

Hi,

It is indeed very disappointing.

I am not a teacher but I also bought a mBot 2.4G version to see the difference between the two models. He seemed to be better suited for schools as it indicated. Now schools will have a big surprise or extra cost for Bluetooth Dongle.

Sad


#4

Yeah, I understand that. But there still is mBlock 3 which can work with these mBots without Bluetooth dongle.


#5

Version 3 is very old, I used version 4.
I believe version 5 should support all Makeblock products


#6

Currently there is no plan to support starter and ultimate 2.0, but well still feedback to the related department. Thank you for your support on Makeblock.


#7

The Ultimate 2.0 can be used with mBlock3 and the 2.4G Serial dongle.
All the other threads are closed, but this is the latest one and is still open. So, I will post here.

d.earth has provided this video on the subject.

and instructions in this one.

https://www.youtube.com/results?search_query=makeblock+ultimate+2.0+serial+dongle

The instructions also seem to be in this post.

That was a good post for the Makeblock Ultimate 2.0 and the 2.4G Serial Dongle.

I have reproduced the instructions as follows . . .

Update Firmware (if required)

  1. Start mBlock3 software (PC version in this example)
  2. With battery power off, connect the USB cable PC to MegaPi
  3. Select menu items:
    a. Boards -> Ultimate 2.0(MegaPi)
    b. Connect -> Serial Port -> COM4 (check your PC’s COM port number in Device Manager)
    c. Extensions -> Makeblock (to enable MegaPi calls)
  4. Load firmware: select menu items:
    a. Connect -> Upgrade Firmware
    b. Confirm the upload completes (“Upload Finish” will be displayed in dialog box)
    c. Close dialog box
  5. Disconnect the USB cable

Run Program

  1. Connect Battery power to MegaPi
  2. Turn on MegaPi: Blue LED on Module will flash rapidly
  3. Press the white “pairing” button on the Module: Blue LED will flash more rapidly
  4. Insert 2.4G Serial USB stick into PC: Blue LED will turn solid blue
  5. Enable 2.4G Serial communication: select menu item
    a. Connect -> 2.4G Serial -> Connect

The combination of the Ultimate 2.0, mBlock3 and 2.4G Serial Dongle does work. At least it did work for me once. However, somehow I have lost that ability. Something is wrong with my instructions and I can not find a combination that is successful.

Can anyone find the missing piece.

It worked again for a fraction of a second. Now it has not worked for hours.

1/19/2019
I got it to work one more time and now it does not work again.
I will try to reconstruct the events here . . .
I plugged in the USB cable and set "Connect -> Serial Port: To COM 6
Reset default program to the only choice: Mega PI
Pressed the “Up arrow” and the motor moved.

Sometimes, the program running needs to be the firmware. I have noticed that the Firmware blinks the light. As follows . . .

Firmware_for_MegaPi_0e.01.016

if(millis() - blink_time > 1000)
{
blink_time = millis();
blink_flag = !blink_flag;
digitalWrite(13,blink_flag);
}

This pattern is one second on then one second off. I would call this pattern “Long Long”.
I can recognize this pattern and notice that it is not always the pattern shown on the board. Meaning that the firmware is not always running on the board. And, the program running on the board will change just by plugging in the USB cable. I do not recognize the blink patterns for the other programs that run on the board, .

Now I can not get it to work again.

And, I am still experimenting to find the secret of this process . . . . . . . . . . . .

To continue
My intent has been two-fold.

  1. To be able to use the “up-arrow key” and all other functions is that group
  2. To be able to have wireless control.

So, in my frustration to complete both items, I have decided to go back to task one and focus there.
Keyboard control should be possible with the USB cable. And indeed it is. With the USB cable I can get keyboard control every time. That is not the problem. However, successfully substituting the 2.4G Serial Dongle for the USB cable is a very rare event.

I have noticed that the firmware code has five “digitalWrite” commands. While one command gives the “Long-Long” blink, the other commands may also be for pin 13 (the LED) and produce other blink patterns that would still be coming from the firmware code. This might indicate that the firmware may be getting stuck in a different mode.

@daveh

@tech_support

Can you help?

Continuing . . . .

I have noticed that the mBlock3 software contradicts itself. The window label says “Serial Port Connected”. But, the option “Connect -> 2.4G Serial -> Connect” does not have a check mark next to it. The software is confused about the 2.4G Serial Port! It is not connected but does not know it!


#8

mbot robots purchased with 2.4g. However, we found that it does not work with mblock 5. We gave 2.4g money in vain. You write that there is no study on this topic in the forums. If you don’t work, why are you still selling 2.4g supported robots? You say you won’t support the old version and you sell us 2.4g robots. You need to take immediate action on this issue. We don’t want to use Mblock3


#9

same from me as well


#10

I have always defended Makeblock because the service I received has always been exquisite. However, how to defend this position. I bought 2.4g robots for school and I have to connect them to USB. It’s pretty sad.

Can we explain that ???

There is not even an indication: Warning, connection 2.4 not compatible with version 5 of the Makeblock software.


#11

I feel cheated, I buy a product in Amazon where the seller is makeblock and I buy the 2.4g that turns out that it does not work in version 5 ???

Buy the product recently … Why do you sell that product if it is discontinued…


#12

Sorry for the inconvenience, I will feedback again.