Makeblock Starter Robot Kit Help


I am trying to get a Robot Tank to work with the makeblock app on my iPhone or the mBlock 5 software on my MacBook Pro.

When I tried my iPhone app, it asked me to plug into a PC and update the firmware.

So I tried to update the firmware by connecting to the mblock software. I can connect to the robot via usb. However, the firmware always fails. I tried turning off my bluetooth, that did not help.

What “sprite” should I select to update this robot’s firmware?
Should it work with the makeblock iPhone app?
I am using Mac OS 10.15.1 on my MacBook Pro

I would appreciate any help you can offer.


I have a starter kit also and it is NOT supported with mblock5. In fact it is an orphan board with a micro usb interface.

Look at this posting from another starter owner


Thank you for your feedback. So am I looking at spare parts here :slight_smile:


Unless you want to work with old mBlock 3 software,it isn’t as modern as mBlock 5 is but it still does the job


Hi dmay,

You can try upgrade firmware for the Starter robot with mBlock 3 software. Then control the robot with the Makeblock APP have a try. I will send you the instruction guiding upgrade firmware for starter with mBlock3 software to your email address. Please kindly check it later.