Laserbox 1.1.5 can´t update firmware


I recently updated the software to 1,1.5 and it appears to be an firmware update that I haven´t been able to update. It has been several days and it just says that the update has failed. I have desinstall and install the laserbox several times and no luck. In the meanwhile in setting>device the firmware space appears in blank


I’m having the exact same problem. I’ve tried in Mac, Pc, different software versions, and still no luck.

Can we get any help from tech support?


Hi Ver0nica,

Sorry to hear that!
First, could you let me know some basic info of your machine refer to[this instruction]( 《How to Report Problem Effectively?》)?

Regarding to the firmware upgrade failed issue, can the machine still works properly (cut and engrave) after upgrading failed? And what is circle led status on the machine when the machine is powered on?

Btw, may I know which country are you in and where did you buy the machine?


Hi alan_vb,

Do you mean you have both the usb connection issue and firmware upgrading failed issue?
If it is only usb connection issue, could you please refer to the reply in this post first?

Btw, may I know where did you buy the machine?
For further info, you can also send an email to for faster communication.


Do I need to login into in able to send the basic info and photos you are asking for?

Part of the failure to update firmware, there are some areas that don’t cut right and sometime the error code Q0X06 appearss. I have cleared cache in the software and in windows,

I have Windows 10, 64 bits. Laserbox software 1.1.5, firmware stays in blank
Machie Serial Number: P1030059190624000001
Machine working hours: 28.6 HOURS

The part of checking points without disassembling the machine, i restart the machine and checked the led status on circle LED button. It is normal after restart, stil won’t update firmware.

I tried to export Work log but it is an eternal waiting and nothing happens.
I open the Calibration for Laserbox and the camera doesn´t turn on. Meanwhile the camera is totally functional when preparing to cut.

I am from Mexico and bought it at Creativakids. I am also waiting reply from them.


Hi Ver0nica,

According to the info, your machine is the first generation machine, please first upgrade firmware to a middle version refer to this link first.
If there is any problem to on anyone of the steps, please kindly let me know the details, thanks!


I went to the first link and couldn’t pass link two. I don´t see the message “result:ok”, it says “invalid request”.

When did the second generation of laserbox came out to te market?



Hi Ver0nica,
Thanks for the info.
Do you still remember the previous firmware version of your laserbox machine?
If it is older than version 019, then normally, the firmware upgrading will be failed when upgrade to the latest firmware 020 directly.
If you are not sure the previous firmware version, please kindly check the current firmware version by this way:

  1. connect laserbox machine to computer with USB cable.
  2. Open the laserbox software.
  3. Open the debug page of laserbox software by pressing CTRL+F1 or CTRL+F1+Fn (Command + F1 for Mac) on windows computer.
  4. Check the current version by clicking on “Get Version”.

Please take a picture for the current version detected and let me know, if it is older than 019, I will provide another easier way to upgrade to 019 firmware first.

For the other question, The new version laserbox which is laserbox pro is already on the market now.
Look forward to hear from you!


It appears number 10 beside X+,X-, and above U-, lb_speed

In case the images won´t upload a popup mini window appears it says

Module firmware service
H3 :
STM32 :
Y1 :
LowPowerPurifier : USB
HUB : 1


Is my Laserbox not the Laserbox Pro? I was told it was. Thanks for you help.


Hi Ver0nica,

To double check whether it is pro version or not, please open the cover of the machine and then check if it has the spring hydraulic lever? If yes, it is laserbox pro. If not, it is the first generation version.

Regarding to the issue, the current firmware version is older than 019. Once the machine is confirmed first generation machine, please refer to the following way to update the firmware to 019 version first:

  1. Open the debug page of laserbox software again.
  2. Then refer to steps on picture below to upgrade firmware to 019 version first.

Once it updates successfully, please check whether it is already 019 version? If yes, please update to latest firmware version 020 by going to menu->help->check for updates.


I could update with step 2 and 3. I forgot the menu > help >check update. I’ll do It tomorrow.

Meanwhile I have finally

My machine does not have the spring hidraulic level, as you mention it is the second check that It truly is first generation.

Being first generation doesn’t mean to be the Laserbox Basic, right? Because Basic Is black and doesn’t have the “draw what you pick”, while mine Is white and does have that feature. So my version isn’t Basic but still not PRO by all means? It still didn’t get to be PRO title? What new features appears in the PRO version that doesn’t have the first generation?
What year did the PRO got out to the mmarket?

Will I have problems later on with next updates? Like computers where they get to the point where new updates are impossible?



Hi Ver0nica,

Good to hear that! Now it has firmware version 019, and you should be able to update to latest version 020. For newer version, there should be no problem for updating.
Yes, the version you have is not the basic version, but it is not the pro version although it has the same feature as the pro version. In the pro version, it has modified some structure inside the machine, but no changes on machine function. The pro version should be on market for about more than one years.


I have gone to menu > help > check for updates. It tells me that I have the latest software version 1.1.5 but doesn’t prompt the firmware update.


Hi Ver0nica,

Sorry, I forgot to mention one point.
Please first connect machine to software, then go to this page and click on the “Official environment”.

Then go to menu->help-> check for updates



" )


The camera still doesn’t come on for the “calibration for Laserbox” software. I will have to open another topic.

" )


Hi Ver0nica

Please refer to reply in the other topic.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.