Laser Engraver Software Update for XY-Plotter V2.0&V2.02——BenBox 2.12.45


Hi Alex_Clarke,

Please set the Microstep Resolution on stepper motor driver to HHL while using benbox.

You may refer to ‘User Guide XY Plotter v2.0 User Guide-mDraw version & Benbox’ for details.
It can be download in this link:


How do I set that on a Benbox P3 board? I literally just unplugged from one identical board to another


Hi Alex,

On the two stepper motor drivers, you can see the Microstep Resolution switches marked with 1,2,3. One side marked as H(High), the other side marked as L (Low), please pull the third switch on each driver from H side to L side.


I don’t have that board, I have one of these: Benbox P3 Redboard


Hi Alex,

You have changed the Board for the XY Plotter v2.0?
Benbox P3 board is not the board from Makeblock, since the board from other manufacturer has different working principle. sorry that I am afraid that I am unable to help.


Wiring different stepper drivers. I have a couple t6600 stepper drivers and would like to run them off my me board. Anyone have a wiring guide. I upgraded my stepper motors and the me drivers dont have enough power to run them.


Hi Jdlauletta,

Do you mean you changed the original stepper motor driver and stepper motor of the XY Plotter?
If yes, I think you need know the circuit diagram and figure out the wire connections, maybe someone who has the similar experience can share the wiring connections.

This link provide all the info for origianl wiring connections on the XY plotter, maybe can provide some references to you:


Hi, I just bought the EleksLaser A3, and it has a new style board that only has one button on it for power. So, machine works great, except laser focus light is on all the time, and it won’t fire the laser unless I push the button on top of the laser, then it’ll never turn off. I can’t seem to find any support for this anywhere. Any ideas on what’s wrong? Using BenBox with Nano selected and LX.hex.


So… powered it up again, and the 2 axis board just smoked. The pins sticking out the right side under one of the stepper driver boards were bent down, maybe something shorted.


I have the same prob, just going round and around and do not know what to do so any help would be tremendous


I think the laser is defective. It should not fire at all without being commanded. I can’t find a replacement either.


Hi Brian,

Do you use the other brand Laser for some personal DIY project? Or you mean the Makeblock Laser is faulty.
It is suggested to use our supplementary laser since we only able to provide very limited support when you modify the XY plotter with other brand components.


This is the laser that came with the kit. The EleksLaser A3 from


Hi Brian,

Do you mean this Laser came with our laser version XY plotter robot.
If yes, please kindly send the receipt for purchasing the Laser version XY plotter to email address:


Brian if your still having this issue, change laser control in second control list from 1q/11 to 12/12 and it works after that had to make that change with mine for the one button board.


i have bought the laser engraving first day it worked good but it was engraving very deep the second day i have tried to work on it all the axes worked but the actual laser light didnt work so it didnt engrave do you think something to do with the software


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.