Firmware update fails


I am unable to get my Airblock to work. When I start the Makeblock App, it connects to the Airblock and immediately proceeds to update the firmware. The update fails and it tries and fails again repeatedly. This is the sequence of screens I get:

  1. In the synchronous information
  2. Synchronization fails, the firmware can’t identify. Please select your device model. (I tap Airblock)
  3. Update fail.

I have tested this with the following devices and got the same results:

iPhone 6, iOS 10.3.3, Makeblock app version 3.0.5
iPad Pro, iOS 10.3.3, Makeblock app version 3.0.5

Thank you for your help!


Hi dingman,

When did you download the Makeblock APP? We have updated a new makeblock APP recently, please kindly update to the latest verison Makeblock APP, then install the software have a try.


This is the latest version, downloaded 11 September. What else could I try?


Hi dingman,

Thanks for your feedback, I have provided feedback to our engineers, will inform you later.


hey there…I have the same problem …I cant use it with my Arduino. Seems the problem is about the firmware upgrade…
any idea so far??


Hi selena1377,

What do you mean about “I can’t use it with my Arduino”? Do you have the Airblock? And you have the upload failed issue while upgrading firmware for the Airblock with Makeblock APP?
If yes, could you give me the system version of your mobile device?


Hi Dingman,

The new version Makeblock 3.0.6 is published, please update the APP and upgrade firmware for your Airblock have a check!


3.0.6 did not help. I still get the same result. I believe this Airblock may be defective.

Tested with:
iPhone 6, iOS 10.3.3, Makeblock app version 3.0.6
iPhone 6, iOS 11.0, Makeblock app version 3.0.6
iPad Pro, iOS 11.0, Makeblock app version 3.0.6


Hi dingman,

Do you have an mobile device with android system?
If yes, could you try connect to the Airblock and upgrade firmware for it with Android mobile device have a check? Thanks!


Good idea. I do not own an Android device but I will borrow one to test with.


It failed to connect on Android as well. I saw the same error messages as iOS. I downloaded the latest version of Makeblock app on a Samsung Galaxy S7 running Android 7.0. I even used a freshly charged battery in the Airblock. There must be something wrong with the Controller Module. I am very disappointed with this product as we’ve only been able to use it a few times.


Does the Airblock ever crash into any hard objects such as wall or the floor?
During the process of updating firmware, did it ever reach to 50% or 90%? Or it always failed at the beginning?


No, it has never had a significant crash. It worked fine until one of the app updates in August.

The firmware update always fails at the beginning, and always with the same error messages listed in my original post.


It has been more than a week since I’ve gotten a reply. Do you have any more suggestions? My Airblock is useless because it is stuck on this firmware update. I am unable to use it in any way.


Hi dingman,

Sorry for the delay replying due to we were on the National day holiday!
We have provided feedback to our engineer and will get back to you soon.


Hi dingman,

How about try upgrade firmware for airblock on the iOS device again.
Please restart the Bluetooth function on the iOS device before you connect it to airblock.

Once still the same error, there may be hardware issue, please kindly send the receipt of the Airblock to email address, thanks!


I restarted Bluetooth, then tried the firmware update and it failed again. I also tested a new device, an iPhone 8 with iOS 11.0.2 and the update failed on this as well.

I have forwarded the receipt as requested. Thank you.


Hi, I have the same problem.
it was working fine (my first day of using it).
I had already upgraded the firmware successfully when we started using it.

We used it a bit, then it said there says a problem, firmware not recognised, upgrade firmware. It only got through less than 20%, and then it said update failed.

Now there are no lights with either battery (which are charged). It does connect to Bluetooth during the firmware update, but does not recognise the firmware.
I choose airblock, and it only makes it until 15 to 16.69% or something like that. Each time it is one of a couple of numbers.
and then the cycle starts again.

Looks like the memory has failed?

I expected it to last a bit longer, can I get a replacement?



I can also mention that it was working great in the play mode.
I swapped batteries,
I started the create mode,
chose land mode,
clicked Play at the top (before building anything),
only then did it complain about the firmware and the cycle began.
the airblock LEDs were the correct colour,
I tried to reload the firmware 3 times (each time failed as I described),
I pulled out the battery, put it back in,
and the LEDs have stayed off since.


Good news!
I tried doing the firmware update from a different phone and it worked!

Maybe the first phone failed because it was running out of storage space?

Does the firmware update require space on the device?