Color sensor isn't working



A few classmates and I are working on a project with the mbot and are using the Me Color Sensor V1 to activate parts of code. They were working fine at first but within a day or two of testing (with probably about a total of 45 minutes to hour of the mbot being on) they no longer work. The LEDs on the color sensor still turn on but when the mbot is first powered up a red light next to the PWR label on the sensor turns on and it no longer detects color.
I tried researching the issue online, but haven’t found anything about it. Does anyone know what the issue is, and if so, how it can be resolved?

Thank you.


Hi Dani

The little red LED on the underside of the module is normal. Nothing else happens until correctly working code is uploaded into the robot (e.g. turning on the light). See my posts at: …

… especially the Oct. 15th entry (for some code that works):


Have you tried stuff like using a different port or unplugging the sensor and plugging it in again?

Have you tried other codes?
Did any event seem to rigger this?

Thanks for your time,


Thank for your response!
We tried unplugging the sensor, plugged it into each of the ports on the mbot, and even plugged it into another mbot to make sure that problem wasn’t with the first mbot.
We tried switching up program, but it still wasn’t responsive.
It stopped working on the program being successfully suddenly in between trials, so I don’t know what could have caused the issue.
Fortunately, we have extra color sensors and they seem to be doing well, so our project should still succeed.
Thank you for reaching out and trying to help, we really appreciate it!


Glad stuff worked out for you!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.