Can't upload new version of my extension

#1 (14.5 KB)

Hi, I have an extension that works fine in mblock. today I tried to upload a new version but I get the “required field extensionName in s2e file cannot be empty” error.

My s2e file is a valid JSON file (checked with multiple JSON validators). Is there some other problem that I overlooked?




This is because one of the processes in our server is down.
Now you can upload/update the extension as usual. Sorry for the trouble



Hi, is possible that the server is down now? I try to upload the own arduino library and give me the same error!?!


@bigeyex I am not able to upload my extension. Is server is down?

Ps. I attach my extension to this post (9.8 KB)


Same problem here uploading my extension. Leave it here just in case it can be done (2.5 KB)


@bigeyex @tech_support I think the problem remains…


Tech support don’t seem to frequent this forum much any more - you might be better reaching out to them by email, that’s the only way I got any proper response from them.


Hi roboteach-es & dnzayan,

Do you guys upload the extension to mBlock3 software for mBlock 5 software.
Here is the new instruction guiding add extension for the mBlock5 software, please refer to it have a try.


Regarding to the problem on mBlock3 software. I have provided feedback of this problem. Our engineer will restart the extension server for mBlock3, please try it later and see if it fixed.


Still no luck: tried 3 hours ago an right now… :cry:


Hi Guys,

Sorry that our engineers had met some problem to solve the problem before. Now ,it should be fixed, please kindly try againa and feedback. Thanks!


Finally I could upload my extension and it’s working now. Thanks! :heart_eyes:

By the way, and for the record, I discovered an issue with my files: my editor (Sublime 3) is configured by default to create UTF-8 files WITH BOM, i.e., 4 extra bytes at the beginning of the s2e file (the actual UTF-8 marker) that the extension center couldn’t deal with… copy-pasting the json in the on-line checkers wasn’t enough, as the json was valid itself, but not the file (at least for the extension-center).

hope this helps someone!

I can't upload my extension to mblock extension center

Can you explain in details how to make my extension can upload to server. Thanks in advance.


I already answered in this thread: