Required field extensionName in s2e file cannot be empty


Hi, can anybody tell me how to solve this problem. I can’t upload my mblock 3 extension. I hope it can be solved because there are someone facing the same problem before. I hope it can be solved a.s.a.p. because i will use it in classroom for students and teacher. Thank you in advance.

Can't upload new version of my extension

Hi there @mohdmaarof!

You should check that your S2E file doesn’t contain any UTF-8 BOM header: in the options of your editor, search for any parameter that says “Save BOM” or “Save Byte Order Marker” and disable them.

For example, I use Sublime Editor and you have an specific option to save a file WITHOUT that header:

If you want, you can share here your extension and I’ll have a look at it.



Wow, thank you so much…really apreciate it…


ZeRo (15.7 KB)
ZeRo (13.1 KB)

Hi. i just follow your instruction, but still cannot. please help me thanks in advance…


Hi there,

Do you get the same error message?

I’m not sure if these two issues are the origin of the problem, but you can try:

  1. Remove the space from the zip file name (and the folder contained in it), or change it for an “_” or a “-”
  2. Remove the tab character in the first line after the “{” (see attached capture)



I’ve delete the space between those text and still extension center give same error

and i open from note pad the format of this file is UTF-8

is it server problem, or other problem occurs when uploading the files.


Everything seems OK. I really don’t know what else to try…

The extension server is quite tricky and picky: maybe you can download the demo extension, rename the files to use those of your extension and try to upload it without any additional changes. Doing this you can check if the server is working, and once you’re sure of that, start changing the file little by little and updating the extension (if you upload the same extension, it’s updated) until you get to the point where it fails. If you discover something, please let everyone know (comment here!).

Maybe you should contact @tech_support directly: many of us had to do it on the past as the server have had several issues before.



Thank you so much for helping me, i will try your suggestion. if i get something new i will update in this forum. :grin::grin::grin:


Today I was working on a new extension and got the same error, and after some investigation I managed to find the cause: the parser in the extensions’ web is much more picky than the actual one in mBlock3: it doesn’t tolerate almost any mistake.

  • Strange characters (“0x20” is invalid, “32” is valid)
  • Comments (can’t add any sort of //)
  • JavaScript callback functions with spaces (“read IR sensor” is invalid, “read_IR_sensor” is valid)
  • Unnecessary commas (the last json field shouldn’t have one)

The problem is that it always report this error for all the cases above, which is misleading. I do leave this information here for future reference and others.

ZeRo Robot (10.1 KB)

Here it is a valid version of your extension: use it for comparison.

Best regards!