XY plotter pen down/up


#1

Hi makeblock,
my new XY plotter runs fine, but lifting up/down the pen seems to work vice versa:
The servo lifts up, when clicking “down” and vice versa.

I can handle this by changing the up / down values in mdraw and raising the pen arm on the back, but that is not a satisfactory solution.

windows, mDraw v1.2.1,

Could you please give me a hint?

regards, Torsten


XY plotter pen down/up, can you help me?
#2

Have you tried to change the pen up/down parameters?
image


#3

Hi,
thank you for your quick reply. I’ve tried to change and this works,
but the pen arm seems to rotate in the wrong direction.
(raising the pen arm on the back side)

regards, Torsten


#4

Hi think,
I am not very sure about that (wrong direction) yet. Will you take some photos of the servo, including the cable connection?


#5

Hi techh support,
thank you for your reply.

1 problem: pen up/down : pls see attached fotos

2 problem : When I try to move the pen home from the last robot arm position, it remains on the position while vibrating. Due to slightly pushing the arm it keeps on moving to home position.
Id could be that the slot 1 of the RJ25 Adapter (limit switch 3 / 4) is broken, because the cable is stuck once.
I’ve made a small video: t-hink.de/wp-content/uploads/2019/09/makeblock.mp4

regards, Torsten


#6

When we press “pen-up” and “pen-down”, it may rotates in clockwise direction or anticlockwise, which depends on the degrees we set. I don’t think that is problem. You may setup an original angle and then setup the degrees, change the original angle, it may move in opposite direction.

To test its limit switch, I will send you a guidance via email.