Won't Show Ports


The Arduino IDE won’t show the correct ports for my starter kit to work. I have checked device manager, since I am on windows, and it won’t show up there either.

What do I do?



Hi zfqlix,

Why do you program starter with arduino software?
You can use the mBlock 5 software to program the starter robot. When add the device, you can add the Orion board.


Hi, thank you for your reply :smiley:

It should be compatible with the Arduino IDE. It says so in the manual. I want to actually code, not to move some colorful blocks around on my screen. My device manager on windows doesn’t even recognize the Orion. How will the mblock software recognize it then?



update: I tried mblock, won’t recognize it there either, as I suspected.


Hi Zfqlix,
On your computer, please install [this ch340 driver](https://www.yuque.com/docs/share/2be4b74b-2227-4023-bec1-95a232447557?# 《CH340 Driver》) manually have a try.

If you still can’t find the serial port of starter under device manager after installed this driver, I may suggest that you change the USB port or USB cable (make sure you use the USB data cable) or even change a computer have a check. If you tried everything but the port is still not available, I am afraid the orion board itself is faulty.

Computer doesn't recognise orion board

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.