Wifi block ios update still won't work


The new ios app that should fix the wifi block connect-problem (1.4.8) still doesn’t work. I get a connection time-out or a message the wifi has made a connection to something else (please disconnect).
I got an early wifi block from the science lab kit.


Hi albertepp,

I received the update of the Neuron application:

  • 1.4.8 for IOS
  • 1.4.2 for Android

Everything is functional but I have my little recipe.

  1. Check the version by going to parameter / About;

  2. Go to the WIFI settings and forget about the network;

  3. Connect the WIKI block and put the PW: makeblock
    Note: I do not put automatic reconnection

  4. Run the Neuron application and connect to the WIKI block.
    Note: if The wifi has made a connection to something else (please disconnect) = Disconnect the WIFI and reconnect.

  5. Configure the Internet by entering your SSID for the Internet

  6. Test a basic program


Hi Crackel,

Thanks for responding.
I’ve been trying over and over, but it won’t work.
In the wifi-settings i forget the neuron-C17586 and reconnect. After that i cancel automatic reconnection.
In the Neuron-app i open a new project by wifi. It takes about a minute to set the network settings. This results in a connection-error (connected to something else i don’t know about) or a time-out.
I don’t understand what you want me to do in step 5. I tried to add the neuron-C17586 manually in the ipad’s wifi settings, but the result is again a time-out…


Hi Crackel,

Step 5 is for when you are connected and functional.
Do you have the model of your iPAD ??? and the IOS version?


It’s an iPad 2018 with ios 13.3.1. I tried on my Iphone SE with ios 13.3.1, same result.
The wifi-block is from the kickstarter science lab kit.


Hello albertepp,

I have the same environment except that my WIFI block from the Kickstarter has been modified. It was crashing and the only way to connect was via FTP with a USB cable under PC. I gave the code provided by makeblock and everything works … This may explain why it works with us.

Conclusion: Are some files in your WIFI block possibly corrupted? Makeblock can help you if they can come back to the forum.


OK thanks, that might be the solution. Makeblock has other things to worry about now, so i’ll be patient.


You could check if you can connect to the Wifi block from your PC / MAC. Plug in USB and type in your web browser:

If the page displays, wait for makeblock, they can make the fix. The engineers are really nice.


Hi Crackel, that works! Do you happen to have that code? I could try to upload.



Even if I had the code, it is too old. I will have to recover it from a WIFI but block. It’s quite simple but you have to change the subnet because the WIFI block is at the address

You put on your computer. You connect with Filezilla to the address and you replace the directory of the block’s website with a functional one.

Personally, Makeblock would be the reasonable solution but it seems to be absent from the forum. Tell me, are you comfortable?


Hi Crackel, it’s ok, there’s no hurry. I’ll wait till Makeblock gets their act together. Thanks anyway for the effort.


Hi albertepp,

Sorry for the delay, do you use the latest version neuron APP 1.4.8 on the ios device?
If yes, but still have the problem, please upgrade firmare for the wifi block have a try. I will send it to your email address via the Wetransfer website since the file is large. Please check it later.




Hi Jonjomatic,
Do you mean you have the same issue to Neuron wifi block?
If so, please tell me the device information and app version.
You can contact me to support@makeblock.com


A firmware-upgrade for the wifi-block solved it, as Crackel predicted. A big hand for Makeblock Support! With their aid the firmware is upgraded by way of terminal.app on MacOs. The wifi-block connects beautifully.


You had to be a bit good at computer science. Obviously you were :rofl:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.