When trying to upload to arduino, it disconects and nothing happens


I have a lenovo yoga, two weeks ago in my robotics class, i could not send the info to legting my group with a bad mark, the next two weeks the same happened. How can i fixit?
PD: I already restarted the laptop, reinsall mblock


Please try to record the issue and send a video to my email box stephanie.wu@makeblock.com.
Also what is the main board you used?
What is the codes you tried?


Her same problem. 1 of 20 times it works, strange, because for months everything worked fine and suddenly ther is a problem uploading the code using the chromebook app, on my Mac device it works fine.
A video: https://youtu.be/jGxeuXc3p7g


Hi henkvdh,

This server should not be stable and this software is not under maintenance, please try mBlock 5/mLink.


MBlock 5? I do not understanding your answer. Why should i use MBlock 5?


So why should it be mblock3?


mBlock 5 is the main software and we will focus on mBlock 5, for other version like mBlock 3 on chromebook, we won’t do any update. The issue like failing to upload or compile in that version, I am afraid the fix is set in a very low priority. In order not to influence your application, we suggest mBlock 5.


but i can not open the program made in mbloock 3 in mblock 5?


Yes. Programs created with mblock3 can be opened with mblock5. (Since you understand your text with automatic translation, it may have a wrong meaning.)


No, a program Made in MBlock 3 I can not open in MBlock 5 there are Some programblocks that dont exist anymore


I’m sorry, it was still wrong.
By the way, can you give me an example of a non-existent block?


mBlock 3’s program is .sb2, while mBlock 5’s is .mblock.
What are those non exist blocks in mBlock 5? We’ll check if we will add later.