What am I doing wrong connecting mBot?


After assembling it I turned it on and tried the line following mode which worked. Then I tried to connect iPad to the mBot but it would not find it. I installed all those apps Mblocky Block, Mbot Block and Blocky mBlock, not sure of the names but something like that. None of found the mBot. Then I installed the Mblocky 5.0 and Mblocky 3.0 to my Laptop and tried to connect using the WiFi with the WiFi USB stick. It would not connect, Bluetooth neither worked from Laptop. The USB cable connected and I upgraded firmware, turned off the App and the Mbot, but it would only connect via cable. Now turning it off the Bluetooth/WiFi chip turns blue and the line following mode stopped working. Any advise?


Hi davidbrok5,

Sorry for the delay. Is the problem solved now?

From your description, I am wonder which version mBot you have? Could you please kindly take a clear picture to show the Bluetooth or 2.4G wireless serial module?

Besides, do you mean the robot can’t follow the line now?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.