Uploading firmware u8glib


Had some trouble uploading the firmware, i installed the library u8glib. And got it uploadet, but the display dont turn on, and I am only hearing a clicking sound.

best regards


Hi Jesper_Andersen,

Do you mean the display on the 3D printer? May I know which 3D printer do you use, could you kindly take a picture for your printer?



thanks for the fast replay

Its the Melephant printer. I am using all the latest libraries and arduino IDE. But their is alot of error message like:

sketch/dogm_font_data_Marlin_symbols.h:12:25: fatal error: utility/u8g.h: No such file or directory

any ides ?


Hi Jesper_Andersen,

Please upgrade this firmware.Marlin (SH1106 Opanel 丝杆换为6.5 ,一体,导程为3).zip (1.4 MB)


Something is stil missing or something, i am getting this error messages.

"In file included from sketch\Configuration.h:815:0,

from C:\Users\Me\Desktop\Marlin (SH1106+Opanel -+©-+++¬6.5 ú¼Ê+¦Õú¼�+¦¦+¬3)\Marlin\Marlin.ino:33:

sketch\thermistortables.h:690:2: warning: narrowing conversion of ‘3.86e+2’ from ‘double’ to ‘const short int’ inside { } [-Wnarrowing]"


Hi Jesper_Andersen,

When did you buy the printer? There are three different versions for mElephant printer

Please try the three files one by one have a check.
3. Marlin (SH1106 Npanel,T6.5,Lead 3).zip (1.3 MB)

2. Marlin (SH1106 Opanel, T6.5,Lead 3).zip (1.3 MB)

4. Marlin (SSD1306 Npanel,T6.5 ,Lead 3).zip (1.3 MB)

[solved] Latest Marlin for mElephant printer
Makeblock melephant firmware not loading


The first one, T6.5 did the job.

thanks for the assistants.


I can´t make any download of the files. Can someone help me?


Please download from links below:

3. Marlin (SH1106 Npanel,T6.5,Lead 3)

2. Marlin (SH1106 Opanel, T6.5,Lead 3)

4. Marlin (SSD1306 Npanel,T6.5 ,Lead 3)


Thanks, Can you tell me what display do I have to select in the latest Marlin? I accomplish to update the firmware to 1.1.4 but the display don´t work…


Hi clarocky,

Could you take a clear picture to show your mElephant printer?
Above three firmwares are for the mElephant printer which doesn’t have the Coupling.

Besides, which one do you mean by the firmware 1.1.4?


Hi Tech_support
I tried to upload firmware 3.malin SH1106Npanel T6.5 Lead3 with arduino 1.6.7.
My machine does’t work, is cheeping all the time and there is nothing in the display.
Can you help me

Peter (Cologne Germany)


Hi Peter,

Could you take a clear picture (mainly for the whole Screw rods) for your mElephant 3D printer?
Besides, did the upload success when you upload the firmware 3.malin SH1106Npanel T6.5 Lead3?


the upload didn’t work without errors.
You will find the pictures under
-> http://www.bastgen.de/Desktop.zip



Hi peterbastgen,

From the picture, it is the printer without coupling too.
Do you mean the upload said failed, but there is no detailed error message? Normally, there will be upload log on the bottom window of the arduino software.
Could you upload it again and take a video to show the upload process? You can send the video to daisy@makeblock.com via pCloud transfer website.

Besides, you may also try the other two firmwares.


I send you the copy the messages of my arduino:
There is nothing on the display of the Makeblock but a permanent cheeping
Here is my screencopy




Hi peterbastgen,

From the error message, it says the programmer not responding, we suspect you might choose the wrong COM port and Board for the 3D printer.
Please refer to this document to choose correct COM port and Board, then upload have a check.How to Upgrade Firmware to mElephant printer.zip (531.3 KB)

Once it still says programmer is not responding, please change the USB port or USB cable have a try.