Upload error on mBot ranger and mBot


Hi everyone,
I use mBlock 3 on windows 10 and mac OS Sierra. I have an error when i try to upload a program on my mBot ranger and my mBot. It’s the same bug on mBlock 5.
Do you know how to fix it ?


You might get more help if you upload some screenshots of the error and a description of how you’ve got the mbots hooked up? Have you tried a different cable, because that sounds like it could be the only common factor.


Make sure you upload the program in the correct steps (make sure to connect with a USB cable, choose the correct serial port and board). Please refer to the steps in the FAQ 3. How to upload my program to mBot.
Tried the first note but still got the error, please remove the Bluetooth / 2.4G module connection from the mCore board, then upload the program again and check again.
If the upload finish displays during firmware upgrade but still fails when uploading the program, please check if there are any other arduino software installed in the system. Please close if applicable
If both the Upgrade firmware and program upload failed, try changing the USB cable, USB port or change the PC to check.

You can refer to some other common errors in mbot at the page below: https://robotsteam.vn/tong-hop-cac-loi-thuong-gap-robot-mbot


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.