Unable connect codey rocky with usb, using Windows 10



I have a codey rockey. We are having issues getting it to connect to the mblock 5 app on windows 10 via usb. A message pops up that says nothing is detected.

  • I tried changing the USB port.
  • I tried uninstalling and reinstalling the mBlock 5
  • I tried uninstalling and reinstalling the mBlock 5 while my antivirus was disabled
  • I made sure the codey was turned on
  • I made sure the codey was not connected to any other devices via bluetooth

I don’t know what else to do and I do not have any knowledge of computer jargon so a search in the forums resulted in confusion for me. Please help.



if the Codey is turned on, Windows should detector: USB-SERIAL CH340


If you do not see the CH340 … You probably have to install a driver … I leave you with Makeblock for the solution


What is that message? Can you upload a photo?


I have the same issue and this is the message:


Please check my email for troubleshooting on this issue.


The forum is illustrative and comprehensive. Even I have also faced this issue and I followed some basic steps then it has been resolved now. Now I am getting another co-related issue with my Avira AVG Error 0xe0010002 don’t know how to fix it. Give me any suggestions.


Hi, have solved your problem. I would like to know the solution to improve my personal knowledge.


Hey I got the same problem as jeccson
But how do I fix that and ter is no ch340 by my settings


Hi jannickmetter,
Please follow the guidance to check if you have installed CH340 driver succeed.
If not, you can download from here.