Ultrasonic sensor blocked at 400


Hi jbdo59,

As YAVUZKAGAN42 claims, the Ultrasonic sensor does not read an infinite distance. It works between 3 cm and 400 cm.


I tried everything you said but nothing worked,
My problem is in mbot .I updated the firmware using mblock 5 and tested the ultrasonic sonic sensor but still it shows 400.
But sometimes when I hold in a certain position only it will just show some values and quickly return to 400.
I tested it in my laptop and in my tablet
No use.
I tried changing the cable,
Plugging the cable with more force,
Changing the port of the sensor from 3 to 1,
Upgrading the firmware,
I was about buy a new ultrasonic sensor ,
that’s when I saw a message from one of the people
Saying that they have also buyed new but it does not work.

This started when I kept mbot for some time without use .
By the way I am using mbot 1


Is the sensor connected to the same port that the code is trying to read it from (port 3)?
Maybe you should try the port 10 instead.
You could just have a bad ultrasonic sensor.