Ultrasonic sensor blocked at 400


I have performed all test as per request. Here are my findings:
The firmware update kinda fixed the problem. The ME ultrasonic Sensor was plugged into port 6 and still not reading anything. I proceeded to test every port from 6 to 10 (ME Auriga Board). The only port that worked with the Ultrasonic sensor was port10. Then I tested port 6 to see of it can be use with something else, the answer is yes. I plug the 7 segment serial display, this worked as expected. I will continue to test port 6 to 9. And report back, but as of now Ultrasonic sensor only works in port10 of my ME Auriga board.


Hi Gtt115,

Thanks for the further info.
It looks like you mentioned everything works when you use the mBlock software on laptop, but not work very properly with the mBlock APP on mobile devices, I’d like to see your program with mBlock APP.

Besides, do you use the latest version mBlock APP? And what is the language settings on your mobile devices?

indent preformatted text by 4 spaces![image|666x500](upload://x3CjPAEBFGcISxja6JmElNU2HGV.jpeg)![image|374x500](upload://8eucuCFKWHJx4OL5sZinjqCl8ib.jpeg)

So here are two pictures from my program. First one I have the sensor on port 6 and the LED segment on port 10 and this does not work then I reversed the port by switching the cable and updating the program and that works. Either there is something wrong with my board or something wrong with the sensor. Both of these items are new may be a month or two old and this is the first time working with them.





Hi gtt115-wc,

From the two pictures, the programs are same. 7-segment display on Port 6 and Ultrasonic sensor on port 10. Was in one situation the selected ports on the code doesn’t match the physical ports connection?

Since the read value from ultrasonic sensor works sometimes, the sensor should be ok. If it works with the same port sometimes, but not the other time, please check if the connection loose and re plug the Ultrasonic sensor have a check.


I am sorry I uploaded the same picture twice. I think the problem is the MEAuguria Board. The sensor only and only works when connected to port 10. Anything from 6 to 9 I get nothing. While this may not be a problem now, but what if I use two sensors in the future. This something that should be warranty. It it very new.


Hi gtt115-wc,

Besides the ultrasonic sensor, do you mean the other sensor (like line follower sensor) doesn’t work either when it is connected to port 6~9 on Auriga board?

From your previous description, you mentioned the ultrasonic sensor works properly when use the mBlock software on the laptop. Could you test again if the Ultrasonic sensor still work with mBlock software on laptop when it is connected to port 6~9?

If all the sensors stop work (no matter use mBlock APP or mBlock software on laptop) when connected to port 6~9, but works on port 10, then we think the problem should be on the Auriga, In this case, please kindly let us know where did you buy the robot and send the receipt to daisy@makeblock.com.


I want to provide an update on my issues where the Ultrasonic Sensor does not work properly. I have taking the time to test the sensor connected to port 6 to 9 and get no output to the 7 segment display. The set of test were executed using an IPhone7 and an IPad. Default language in the iPad is English and on the iPhone I have English but also use a Spanish keyboard settings. The qSame result on both the ultrasonic Sensor only works when connected on port 10. Port 6 to 9 does work with other items. Now when using my laptop there is no issues with the ultrasound sender. I can connect to any port from 6 to 10 and it works. This may be an issue with the iPhone and iPad app. If tech support needs more info please let me now. Thank you.


Hi gtt115-wc,
Do you mean the value of the Ultrasonic doesn’t show properly on the 7 segment display when the Ultrasonic connected to port 6 to 9?
Here we have done a test with the same programe and found the 7 segment display shows the distance value of the ultrasonic sensor properly. I wil send you the video to show the test process via pCloud transfer website. Please kindly check your email address.

While, we find the Ultrasonic value showing on the APP does function abnormal, it shows at 400 most of the time when the sensor connected to Port 8, but change properly when sensor to port 10. For this part, we will provide feedback of it to our APP team to optimaze it.

If both the values showing on the APP and 7 segment display function abnormal on your side, please set the default language and keyboard settings to english to have a try.


There is a very interesting situation. Like that; when ultrasonic sensor assamble on ranger, screen show 3cm. But separete ranger and ultrasonic sensor, screen show true value.
Note: sorry about my english level.


Hi GoksuARAS,
Not sure how did you test “separate them”? Connect ultrasonic to another board?
In my test, ports 6-10 all shows correct distance value. On App, it will change when I move the obstacle.
When you test, you may record video and send to my email stepahnie.wu@makeblock.com via https://transfer.pcloud.com/


Hi tech_support,

I have also the same problem with the ultrasonic sensor of my mbot.. using mblock app > mbot > 8: compare - 1, ultrasonic sensor always displays 400.  But before I was able to performed 8: compare 1 to 6 and effectively use the ultrasonic sensor.
After experiencing the problem (always displays 400), I tried to upgrade firmware using mBlock 3 for PC v3.4.12 and do the test for ultrasonic sensor as per previous advice to Moaiamorfo - Oct2016. But still I have the same problem.
Do I have to replace my ultrasonic sensor with new one?


please check your email box.


Hi support, i’m facing the same issue after i downloaded the mblock 5 and do some firmware updates. Now i’ve tried to update to factory firmware with mBlock 5 or even mblock3. I still not able to get the ultrasonic sensor working. It keeps being stuck at value 400. I have tried reseat RJ25 cables, replace RJ25 cables but no help. Please help


Hi missyoumuch, may be you can send a video to support@makeblock.com or Icy.feng@makeblock.com.


Thanks gtt115-wc !!!
Using port 10 solved my problem with the ultrasonic sensor as well!

I have tried only port 6-7 before (the color coding is the same), and it worked from my PC, but unfortunately it did not worked from the Android App mBlock. Since the levels are locked in that app, and there was no way to unlock them without finishing the previous level, it was a HUGE problem.
Now my son can continue learning. He is so excited! :smile:
Thanks Again!


Dear tech_support,
i have the same issue with my ultrasonic sensor stuck at 400 using my mbot. Firmware is updated, cables are fine. I bought another sensor to sort this out but nothing change. Anyway to get in touch with you online? Thanks!


because mbot use ultrasonic distance sensor and it see max.4m