Talkative Pet Add-on Pack - Can't Upload Programs to mBot


#1

Hi there. We have the mBot Talkative Pet add-on pack and we’ve never been able to successfully upload the software to the mBot in makeblock 5. We continue to get code errors returned (we’ve just used the case program code made available by makeblock without any edits) that we can’t figure out how to troubleshoot. The kit is cool looking but without the working program for the add on it’s been pretty frustrating. Hope someone is able to help troubleshoot as we’d love to get it working like in the videos. Thanks!


#2

Hello waggette. Is mBot powered on while the programming is uploading?


#3

Hi, thank you for the response. Yes, the mBot is powered on and connected via usb. I have the latest version of makeblock installed from the website and I’ve attempted the upload with both the factory firmware as well as the updated firmware installed on the mBot. In all instances I receive the same error previously shared.


#4

I too get this same error. Very frustrating. Tried adding as many extensions as i could hoping it would fix it.
No luck, please help.
One disappointed daughter.


#5

Hello Waggette and Wa66, I just checked and the programs for the add-on packs are written in mBlock 3, and the format is .sb2, right? If so, you will be able to open the files with mBlock 5, but there are some blocks are in red color, which means those blocks are undefined in mBlock and you need to change them. This is the reason that why there’s error report coming out when you upload it in mBlock 5(from the screenshot I think it’s mBlock 5).

To solve it, please use mBlock 3 and upload the programs into your mBot. I think this will help you.