Running motors on Port 4 - Makeblock Megapi


#1

Hello,

I’m working on a project that involves using all 4 ports to run 8 DC motors. I have been successful in using Ports 1 - 3 to run 6 motors, however I cannot get Port 4 to work. Here is what I have tested and tried so far:

1 - tested different combinations of motors I know are working on other ports
2 - swapped Makeblock Megapi Encoder/DC Motor Driver from other ports
3 - tested using “MeMegaPiProDCMotorTest1.ino” code included with Makeblock Arduino libraries, all Ports except 4 work

I have even purchased another Megapi board because I though maybe it was an issue with mine, but I have the same problem.

I feel like I’m missing something obvious but I’m not sure what that is. Could it be a power issue? I am running the board off the 6X AA battery power supply that is included with the Ultimate kit.

Any help or suggestions would be greatly appreciated.

Thank you!

Ian


#2

Hi there:

Do you have parameters of the DC motor’s power? because you need to make sure the power of 6X AA battery can supply 8 DC motors,our hight-power robot ranger was power by 6V-12V/2A and it has only two DC motor,so it could be the issue of battery,maybe you can use 18650 battery to have a try


#3

Hello,

Thanks for the response. I do not think it is a power issue as I can remove all the DC motors from the other ports and the Port 4 motors will still not run. As I said before I have also tried swapping motor controllers and motors and this does not work as well. What I find really strange is that I have the exact same problem on another Megapi board I just purchased.

Could it be and issue with the code? Or is there something I need to toggle? It is my understanding that I should be able to run two DC motors on each port, and all three of the other ports (Port 1 - 3) work on both boards.

Thanks again.


#4

Hi:

We just discuss this problem with engineer,our opinion is maybe the current of 8 motors exceed the
limitation of MegaPi,but we arenot 100% guaranteed about that,so could you please send your codes to this Email account:support@makeblock.com.thankyou.


#5

Hello.
I have the same problem - the MegaPi port4 does not work.
I have - 2 MegaPi, 4 MegaPi Stepper Motor Driver + 4 Stepper Motor, 4 MegaPi Encoder/DC Driver +4 180 Optical Encoder Motor + 8 DC Motor.
I tried many different connection options - port 4 does not work.


#6

The problem has been resolved. It is necessary to choose MegaPi, not MegaPi Pro.
Еverything will be ok.


#7

123456


#8

Hi there:

Glad to hear you fix the problem by yourself,if you still have any problem please contact with us.