Reset mBot Ranger to default program



I want to reset my mBot Ranger in mBlock 5 to the default program. When I connect the Ranger via USB I can upload the Online Firmware(09.01.017) to the Ranger but I cannot select uploading the default program. How can I completely reset the Ranger?

Since I have uploaded the 1st program to the ranger it looks like that when I upload the Online Firmware that the 1st program is active on the Ranger as the Ranger starts moving after switching it on.
Additionally since the 1st program was uploaded I cannot connect anymore with my mobile App to the ranger. It says I need to upload a new Firmware (which I did).

My last question is regarding mBlock 5. Everytime I open mBlock I need to add the Ranger to the Devices. Why does mBlock 5 not remember that I have selected the Ranger the last time?

Thank you for your help,


the firmware is a program. You can either have the firmware on the ranger or your program on the ranger.

There is a blue star you can click on when adding a device and this will make it your default device on startup


Hello OutoftheBOTS,

Thanks for the hint with the blue star! That´s works.

Do you know how to reset the Ranger to the initial setup as it was delivered?
The App on my mobile cannot connect via Bluetooth but tells me to “use the PC version of mBlock to restore firmware”. When I upload the Online Firmware(09.01.017) via PC then the Ranger starts moving according to the first program which has been uploaded.
When I have got the Ranger I could connect to the Ranger without any problems via Bluetooth and control it by my mobile phone. But since I uploaded a program I cannot connect any more with my mobile via Bluetooth (Bluetooth with my PC still works).

Do you have any ideas?



Hi Lara
How are you uploading the firmware? Do you go into mBlock, open up in Live mode, connect then update the firmware there?

I’ve put up a video here: of the upload process

Once this is done, your ranger should be running the standard firmware (i.e. back to factory settings). If you’re doing this, do you get any error messages? DO you get a message saying the upload was successful?


Hi MurrayElliot,

Thanks for your suggestion. Yes, I downloaded the firmware as shown in your video.

I connect the Ranger via USB to my Computer in Live mode. It says “connected”. Then I go Settings and Update Firmware and select Updates: Online Firmware(09.01.017). After the update is complete I get the confirmation “The firmware update is finished!”. I press OK. The Ranger is now disconnected. I unplug the USB cable from the ranger.
When I then turn on the ranger it starts moving after about 1 second. Hence for me it looks like that there is still some program on the Ranger. When I used the Ranger before uploading a program after putting it together it did not move after switching it on.

What do you think?



Hi Lara, sounds very odd.

What happens if you use mBlock in live mode and write a program to do a few simple actions? Does it operate correctly while tethered to the PC? That would suggest the firmware is loaded and operating correctly.

Can you double check all the connections to the motors etc are correct as per build instructions?


Yes, when I tell the ranger in Live mode e.g. to turn light up in red for 1 sed and play a note it when hitting the space it does so.
But when I switch it on it starts moving forward.

I rechecked the connections but I assume they are fine since at the beginning I could control the Ranger by my mobile phone on the app. I´s only since I uploaded a program that I cannot connect to my mobile phone any more and the Ranger starts moving after switching it on.



PS: when I switch the Ranger on and it starts moving it still accepts the Live command of to turn the light up. But it keeps going on an on…


That’s very curious and might suggest a short circuit somewhere. Can you make sure there are no metal pieces contacting any of the electrical components?

If it’s not a contact issue, then I think I’m a bit out of ideas, perhaps @tech_support will come along with some suggestions.


Thanks MurrayElliot,

I have checked the Ranger but did not find any short circuit. I have contacted the TechSupport.



Hi Lara,
Firmware 09.01.017 is the factory firmware for Ranger.
It should work to app when running at this firmware.
If not, please double check if firmware update succeed.
You can also try to reset to factory firmware using mBlock3 which can be download from here
1)Connect to the right port.
2)Choose board Auriga.
3)Reset default program.
Please try and tell me the result.


What do I do if I only have access to a Mac because I cannot run makeblock 3 anymore.


Hi cricketmad23,
So you have met the same problem with Lara?
The Ranger will move itself even you have reset to the default program?
To this issue, please confirm if you have ever change the building forms.
If yes, that may caused by the previous firmware in new form.
To solve the program, please connect your robot to the Makeblock app when it is running at default program.
If you assembled land raider now, please go to play and choose drive.
If other form, please choose the correct form from Makeblock app.


No it is not updating the default program at all.
When I plug it in it tells me to update the firmware.
I click update and select the Online Firmware(0.01.017).
The update will get to between 2 and 70% and give me an error.
If I run mLink first both makeblock 5 on my mac and the online mode will get through the download, I click ok and it disconnects. I click connect again and after a few seconds it is asking for the update firmware again.

It was running fine and well through live and bluetooth but I had to upload a program to the robot and it has not worked since.

I have tried recharging the batteries, non rechargeable batteries, the reset button on the unit, running the code through live, the apps and via bluetooth (all give me the update firmware error).


Hi Kylie,
I received your email.
As I have mentioned in the email, i will ask Stephanie to follow the case.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.