Problem to connect via bluetooth to mbot ranger


Hello, i buy a mbot ranger id#26635 and test to Connect from the following devices and obtain a “incompatible device” error

  1. Iphone 5, iOS v11.2.1
  2. IPad 2.0, iOS v9.3.5
  3. Samsumg J7 android v7.0

Anyonne know what is the problem?



Hi willys,
Which APP do you use?
To control the mBot Ranger with mobile devices, you can use the Makeblock APP or mBlock APP.
For the above two APP, they required system below on mobile devices:
iOS: iPhone4S/iPad 3, iOS 9.0 and above
Android: Android 4.3 and above

Among your devices, I think the IPad 2 won’t work. But for the issue “incompatible device” happens on the other two devices, please make sure you are using the correct APP.
Once still the same issue when using Makeblock or mBlock APP, please reset default program for mBot Ranger have a try.


iPad 2 will definetely not work.


WHY? It’s running IOS 9.3.5. I am having the same problem, also with iPad 2 running 9.3.5


Hi Timbo,

The Bluetooth module on our product support BLE protocol, for Apple products, only the products published after the year 2011 support BLE protocol which can work with the Bluetooth on our product.
Since the iPad 2 doesn’t support BLE protocol, so it cannot work with our APPs which need connect with Bluetooth.

The APPs of our product work with iPad 3 and above and the iOS should be iOS 9.0 and above.


Hi i have mbot ranger i use my ipad and my mc to operate it. I use makeblock5. My bluetooth is not working and not being able to discovered app. It always shows a blue solid light and reset button is not working. I have reinstalled the bluetooth chip and updated the firmware still it is not working even my motors are not working. When i connect my mbot ranger by usb for remote control opperation it follows command but do not move. I have tried all possiblity even my bataries are new. Please help


Only motor are not moving? Have you tested other module like onboard leds?
You may take a video to show the issue and post here.
For the Bluetooth module, please try to unplug and plug it back.
Can the ipad detect any other Bluetooth device? And which App you used?
Does it work before?
When and where did you purchase it?