Problem Connecting mBot to mBlock5 via USB


#1

Hello,

I am facing problems connecting mBot to mBock 5 via USB. I connected my device visa USB to mBlock 5 on windows 10 and no com devices are shown although mBot is turned on.

The connection using Bluetooth worked well but it only allows live, no upload is allowed.

Can somebody please assist on hints on what could be the problem?

Thanks.


#2

It could easily be the CHG340 driver see https://www.mblock.cc/doc/en/faq/ch340-driver.html


#3

Yes mohamed.3asem,
Please install CH340 driver and try again.
By the way, may I know the operating system of your computer?
Thanks.


#4

Thanks gents for your replies.

I am using Windows 10 Enterprise.

I installed the CH340 driver from the link above and still the device manager doesn’t recognize my turned on mBot after connecting it via USB.

After some research I also tried to disable driver signature enforcement using test mode in windows 10, still same problem.

image


#5

Hi mohamed.3asem,
Please take a screenshot of the configuration about your computer and send to support@makeblock.com
By the way, is there any error message when you install the CH340 drvier?
If yes, please also send me a screenshot of the error message.
Thanks.