Nothing is uploading to my mBot! HELP!


#1

I have my mBot for a quite while. But today my robot didn’t wanted to upload anything to it… I updated the Firmware, The Application, The Arduino Driver even reinstalled windows but it didn’t seem to help. So i changed batteries as well, Nothing changed. I need help as fast as someone can reply because the competition starts for 5 days and i don’t have much time.

I use Windows 10, mBlock 5 and i have 4 Duracell batteries.


#2
  1. Did you pick the right device in Makeblock 5? By default it is Code Rockey, you need to create a mBout

  2. Alternatively, try it with Makeblock 3


#3

Yes i picked the mBot device, i tried with makeblock 3 and it didnt work


#4

Please post a screenshot of the error you get during upload.


#5

Which firmware are you using? One is compatible with tablet, and one is compatible with computer. If you have the tablet version then your code will look like it’s uploading, but nothing happens.


#6

Hi CyberLuka098,

Is there any error message during upload personal program or upgrade firmware?
Could you please upload the following program to the mBot and take a video to record your operation as well as the problem phenomenon? (You can send the video to my email address:daisy@makeblock.com via WeTransfer website)
image

Besides, please check if the mCore board is okay or not by uploading the blink program to mBot with Arduino software integrated by mBlock3 software. Please refer to this attachment
Test if the Arduino board is working or not with the Blink program.zip (684.4 KB)

Btw, have you tried change the USB cable or the computer?


#7

no errors, just says sucesfull upload but nothing uploads


#8

Have you tried uploading to a different mCore?


#9

i dont have other mbot, only one


#10

i tried other usb cable, nothing different. I dont have another computer or mbot. I will try that piece of code…


#11

I’m using online firmware 06.01.107 (mBlock for Windows PC 5.0)


#12

Hi CyberLuka098,

Look forward to your further feedback after tried the suggested code.

Besides, you can also try upload the factory firmware (06.01.009) with which you can play the mBot with IR remote controller or switch the three modes by pressing the on board button.

The online firmware (06.01.107) is a firmware for supporting debug online firmware. Usually mBot will not have special performance when the online firmware uploaded successfully.

Here is the difference between online firmware and factory firmware for mBot to you for reference:
a. if you have done the process about “upload to Arduino”, and you want to use the default function such as “object avoid mode”, “line following mode” please choose “factory firmware”;
b. if you want use mBlock to program the boards, “online firmware” could support all function blocks shows on the script pane;
c. The reason of the different between two setting is we could access the memory limited of the arduino chip to put all factory default program and support all function blocks in mBlock.


#13

Hi CyberLuka098,

I just find the video you sent to me.
According to the video, I think there may be issue on the mCore board. Could you help test the mCore board with the document I sent before?


Please kindly let me know the test result.
If the mCore is really faulty, please kindly send me an email with the info below:

  1. Where & when(the date) you bought the robot kit?
  2. The purchase receipt of this mBot.