No bluetooth connection after default programm on Makeblock Ultimate 2.0


Hi everybody!

We (my ten year old son and I) just connected our makeblock Ultimate 2.0 to the mbot program on the Laptop. All worked perfectly well but after sending the default programm to the Roboter (in order to use it with the smart phone app again), we are not getting any connection between the smartphone and the roboter.
Bluetooth is seeing the roboter but it is not getting connected in the makeblock app as is does not find the roboter.

before connecting it with the mbot program we never experienced any issues with the smart phone - roboter connection.

ist there anybody who can help us please?

Thanks and regards,


Hi Sam,
May I know which software you use to update the firmware?
Also please make sure the upload succeed.
You can share me the information to


Thanks for your message.
We downloaded the Software from the makeblock Internet site. It is mBlock 3for Win 7+
Version: V3.4.12

Before that we also tried the mblock 5 for windows Version V5.2.0. but that did not work as it did not show the toolbar so it was completely useless and we deinstalled it again.

I would be glad if you could helps us!


Hi Sam,
If you use mBlock3 please just make sure you choose the right board and also the right firmware.