Neuron Wifi issue in Neuron APP for Android


#1

I just bought the “Neuron Creative Lab Kit”. It probably was the last set available in Poland.
I am testing communication Neuron App for Android with Neuron blocks. Bluetooth communication works correctly. I see other modules connected to the Bluetooth block in the Neuron App.
I can not connect to the WiFi block in the Neuron App. I do not see I see other modules connected to a WiFi block, for example a camera block.
First on my smartphon I connect to the Nueron WiFi block (access point -> neuron-xxxxxx). Communication in the Android system is correct.
When I go to the Neuron App, the screen says “Connect your Neuron Blocks” I choose the right big “Wi-Fi connection” icon. Then the following message appears: “Get the WiFi block ready. Switch on the power supply and check if the WiFi module is blinking blue light.” There is a graphic on the screen with a flashing LED in the WiFi block. In my block, the LED is not blinking. When I click on the message: “The Blue Light is not blinking?” in the app, a message appears: “If the blue light is solid, you have to have a block of older version. You can ignore it and click ‘The Blue Light is Blinking’ to move on.”
Why WiFi communication does not work and I do not see any blocks in the app?
I tried to solve the problem myself. I reset the WiFi block with a pointy element. I can connect my laptop with a WiFi block, enter: 192.168.100.1, I can log in and see the configuration. I do not know what to do next.
Why in my WiFi block, the LED is not blinking? Is there an older version of the WiFi block in the “Neuron Creative Lab Kit”? Do I need to update the firmware in the WiFi block? If so, how to do it safely?
Please help.


#2

Hi P_e_t_e_r,

Personally, I have an old block WIFI and a new block WIFI and it blinking or not blinking, I do not care anymore.

Step # 1: This connect to the WIKI block and enter the password: makeblock. Do you seem to be missing the password?

Step # 2: Leave the application and establish the connection. Usually, 5 sec. is sufficient to establish the connection.

Note: Warning, I used to forget the network to enter the password again because sometimes I can not establish the connection. That may be your problem.

Final problem (Update): If all this does not work. You probably put an update that went wrong. Good news, since you are able to connect to 192.168.100.1 from your laptop then you can fix it. See with Makeblock, they are super good.

here, I hope it will help.


#3

Hi P_e_t_e_r,
If you have tried everything and still not work, please download the instruction here and manually update firmware for the wifi block:
http://download.makeblock.com/Neurons.rar
If you use mac os, please try to download this one:
http://download.makeblock.com/mac+neuron%20wifi%20update.rar

Look forward your reply.