Need help with firmware restoration


#1

I got the makeblock ultimate 2.0 and built the robotic arm tank and it suddenly stopped working. When I try to connect to it through the phone app it says to restore firmware through the PC. I try to update it, and it gets to about 5% and then fails. How do I fix this? batteries are brand new, I tried with the Bluetooth module plugged in and unplugged, and it won’t update. I also can’t control it through the PC app when it is connected with a USB cable.


#2

Hi iamreallyhungry,
To update firmware for Ultimate 2.0, please install mBlock5 to your computer, you can download from here.
https://www.mblock.cc/en-us/download

After you have installed the software, please following the steps to update firmware for your robot.
1)Connect your robot to the computer with USB cable, open the software and click connect.
image
2)After connected, go to setting and you will get the option to update firmware.
image
Please confirm your steps and send me a screenshot of the error message if still failed.
By the way, may I know the operating system of your computer?
Thanks.


#3

I am on Windows 10. I uninstalled and reinstalled the program, tried with the device powered on and off, with the Bluetooth chip plugged in and unplugged, and in all my separate USB ports.


#4

Hi iamreallyhungry,
If so, please try the test version.
I send to you by email, please check your inbox.
Thanks.