Naming Program on CyberPi


#1

Not sure this is the right forum.

Programming with mblock5 for cyberpi on windows.

Everything going ok, but when I upload a program to the cyberpi, it replaces one of the entries in the program list. This is as documented and not a surprise. But the name of the uploaded program is always “main”. Not “Program1” or “Program5” or anything else.

This gets confusing because you have to remember whether “main” in slot 1 is the program you want, or “main” in slot 5.

Fine for me, but confusing for my daughter (9 years old).

How can I change the names of the loaded programs shown in the program list on the CyberPi?

Thanks,
j


#2

Hi devnull,

You’ve come to the right place for help.

  1. Click on the button: Home
  2. Select a program from 1 to 4 (be careful, it will be overwritten)
  3. You name your program in mBlock, no need to even save in the Cloud (just put a name)
    2021-11-20%2016_27_27-mBlock%20Block-Based%20IDE-%20Coding%20for%20Beginners
  4. Download and the name of the program will be in your CyberPi

#3

Thank you!

I tried that, but it didn’t work. I’m using mblock 5.3.5 on Windows 10. Used the Upload option.

Here’s the menu line from mblock:

And here’s the program list on CyberPi (cropped for size)

I’ve looked at the python generated and at the sample programs and don’t see anywhere else to set the name.

What should I try next?

-j


#4

Hi devnull,

I thought you were using the other environment. However, you said Python and indeed I am unable to name the programs. Maybe Makeblock has an explanation?


#5

Hi Crackel,

I’m programming with the block based system, not the python editor. But I took a look at the python generated to see if the program name was getting defined somewhere else. It must be, but I haven’t found where yet.

Also, I’m not using the browser/mlink based environment, I’m using the native windows program. When I get a chance, I’ll try the web based system.

J


#6

Hi,

I tried local 5.3.0 and 5.3.5 and nothing works. only the web version, but not in Pyhton … You will have to switch to the web with mLink 2 … It’s going pretty well.

Sorry for not having found a solution. Makeblock will take over …


#7

You did find a solution! The online editor worked perfectly.

And Makeblock has a bug to track down in the native version - something that I know that programmers JUST LOVE :frowning:

(having tracked down a bug or two myself…)

-j


#8

Hi:

Glad to hear your guys have found a solution for this problem,if you still have any problem about this feel free to contact with us,thankyou.


#9

Hello Makeblock,

Indeed, there is a workaround with the mBlock 5 + mLink web environment but the problem is still present with the mBlock 5 (Python) + mlink web environment or the Local version of mBlock 5.

This should work in all mBlock 5 environments. I didn’t try with tablet apps (IOS / Android).


#10

Hi:

ok,we’ll feedback this problem to our software engineer,thankyou.


#11

Hi Crackel:

Our software engineer said this problem will be fixed in next version and thank you for your feedback once again.


#12

Hi Makeblock!

Thanks for looking into it. For completeness, I also tested on Android (Mblock app, version 2.1.3). This does not correctly set the program name either.

-j


#13

Hi there:

This problem will be fixed in next version,please wait patiently.


#14

Hi team, just tried the latest version of mBlock (5.4.0) and it’s still not working.

I have tried online editor & mLink and it does work - BUT: i can only seem to upload one program at a time, everytime i publish a new one it will overwrite the previous one, as they are always placed in second position on the CyberPi.

Is that expected behaviour or am I missing something?

Many thanks


#15

Hi oscarthewhiz,

Did you try changing the program before downloading the program? Ex. Select program 3 and then download so that it overwrites program 3. I’m not sure how it works but I think that was the behavior a few months ago.


#16

Thanks for the quick reply @Crackel. Yes, i actually tried this last night and it did work, which is a bit weird.
I do wonder if there is a limit of separate programs you can upload - at the moment I seem to have 8 ‘slots’ available.

Just to clarify again for other users: to permanently upload multiple, named projects to your mBot2 / CyberPi you need to go through the following steps

  1. sign up for a makeblock account if you havent already
  2. code your scratch project in the online editor https://ide.mblock.cc/, give it a name
  3. connect to your mBot2/CyberPi using the mLink helper app https://mblock.makeblock.com/en-us/download/mlink/
  4. select an existing program slot on your mBot2/CyberPi. Careful, this slot will be overwritten with your new program!
  5. upload program