My Codey Rocky can’t run code


I am having 2 major problems with my Codey Rocky.

  1. My Codey Rocky can’t run Code. When I use the app on iOS, all it does is say it is running but the Codey Rocky does nothing at all, doesn’t make a face, a sound, doesn’t move, buttons don’t work, nothing works.

  2. When I try to code on the computer (Web), I run into the same problems. So, logically I downloaded the software. The software couldn’t download because on MacOS, Apple couldn’t check it for malicious software. So, I tried ChromeOS, can’t run code; Windows10, can’t run code; and finally Linux, guess what,


I’m tired of trying to figure this out, this is a very unintuitive product even for people like me who are tech savvy. Can anyone help troubleshot?



Hi Adrian,
Please double check the version of the software that you installed.
Make sure you are using the latest mBlock5 V5.2.0.
Also, please update firmware for your Codey and try again.
To update firmware for Codey, please install mBlock5 to your computer, you can download from here.

After you have installed the software, please following the steps to update firmware for your robot.
1)Connect your robot to the computer with USB cable, open the software and click connect.
2)After connected, go to setting and you will get the option to update firmware.