Mlink2 does not upload


Using mlink on chromebooks and a pc with my students. Worked fine until about 2 weeks ago. Cannot put a variable in a motion block command. Cannot put sensor value into led display using show number. I get the error message as below. Also cannot use bluetooth controller code specifying joystick. Everything works if I use pc mblock version 5.3.5. mlink version suddenly seems to handle numbers differently. Cannot change number type. Is this a “server side” problem on your end? I am using the latest mlink version 2.1.1

In the png file of code, i receive the upload error when I use variables such as left and right in the motor command. If I replace variables with actual number like 25 it works. Is this a variable type error?

Like I said this was niot happening about 2 weeks ago. I have noit heard anything from an email to tech support. I am trying to help students. Thank you.


Hi detnire,

The problem is probably in the mLink of the chromebook because on Windows it works fine. Can you show me the code that this generates by clicking here:

When I get the code I will find the problem and look for a solution


Thanks for writing. The error occurred on both chromebooks and a PC using MLINK2. The same code worked fine on each platform until about two weeks ago. The code has always worked using mBlock 5.3.5.

Noticed about an hour ago, the code now works again using the chromebook and PC using MLINK2. In my readings, I gather there is a server side to the MLINK2 program as it is web based. Did something change on the “server side”

I looked at the arduino code version of my code and I can see the variable I created inserted within the formula in the command block. I also read somewhere in a forum that mlink declares variables like arduino. However, you cannot declare variables in Mblock or Mlink. The Type error I was getting and the quasi solution made me think my variables were being declared as a string and therefor could not be used in a numeric command block like motion commands or inserting a sensor reading into the LED display.

I never did get a reply back from Makeblock tech support through my forum entry or direct email. Work again but a reply from Makeblock would be nice.



Thank you for your feedback we’ve fixed this problem,please try it again.